summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-08-23 23:14:51 +0200
committerMichał Górny <mgorny@gentoo.org>2015-08-23 23:15:10 +0200
commit556fafc1c0b8554ba3d8db9ba9112e0e7f5a46c8 (patch)
treeed20422c0b81ece3ebef2cbafd810ef498e7a08f /dev-util/xdelta/xdelta-3.0.10.ebuild
parentx11-plugins/wmnetload: EAPI bump, fix compilation with new libdockapp (diff)
downloadgentoo-556fafc1c0b8554ba3d8db9ba9112e0e7f5a46c8.tar.gz
gentoo-556fafc1c0b8554ba3d8db9ba9112e0e7f5a46c8.tar.bz2
gentoo-556fafc1c0b8554ba3d8db9ba9112e0e7f5a46c8.zip
dev-util/xdelta: Version bump
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-util/xdelta/xdelta-3.0.10.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-3.0.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-3.0.10.ebuild b/dev-util/xdelta/xdelta-3.0.10.ebuild
new file mode 100644
index 000000000000..915d7f9bbf05
--- /dev/null
+++ b/dev-util/xdelta/xdelta-3.0.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=xdelta3-${PV}
+
+DESCRIPTION="a binary diff and differential compression tools. VCDIFF (RFC 3284) delta compression"
+HOMEPAGE="http://xdelta.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.xz"
+SRC_URI="https://github.com/jmacd/xdelta-devel/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples lzma test"
+
+RDEPEND="lzma? ( app-arch/xz-utils:= )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_with lzma liblzma)
+}
+
+src_compile() {
+ # avoid building tests
+ emake xdelta3
+}
+
+src_test() {
+ emake xdelta3regtest
+ ./xdelta3regtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-binPROGRAMS install-man1
+ dodoc draft-korn-vcdiff.txt README.md
+ use examples && dodoc -r examples
+}