summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/xmlindent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/xmlindent')
-rw-r--r--dev-util/xmlindent/Manifest1
-rw-r--r--dev-util/xmlindent/metadata.xml10
-rw-r--r--dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild35
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/xmlindent/Manifest b/dev-util/xmlindent/Manifest
new file mode 100644
index 000000000000..d60cc002cb5f
--- /dev/null
+++ b/dev-util/xmlindent/Manifest
@@ -0,0 +1 @@
+DIST xmlindent-0.2.17.tar.gz 18333 SHA256 3a0f6887b696087b8dad4901d3994954214dbbd78499eaf622b9a85060cf254c SHA512 ab4b46dbd68f29e7adba6283485eb9d1c614ece640c18e1eabbe7f0e1e6f27f14d00d694e4e1981aaf66e0ddcf208c6cb2c80dda1cbeb0ceb1a40987a419f716 WHIRLPOOL 28b9ea143efb19152554ef5aa69dce6dd0652df3bc84ff36fc23ac9ac7804b3b43716917b0bbc043bf37680df492c0c1cd9358644b22b2037c4fc15baeee3c01
diff --git a/dev-util/xmlindent/metadata.xml b/dev-util/xmlindent/metadata.xml
new file mode 100644
index 000000000000..bfcd6bf8d100
--- /dev/null
+++ b/dev-util/xmlindent/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-tools</herd>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xmlindent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild b/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild
new file mode 100644
index 000000000000..e853bfe620a5
--- /dev/null
+++ b/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="XML Indent is an XML stream reformatter written in ANSI C, analogous to GNU indent"
+HOMEPAGE="http://xmlindent.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xmlindent/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|gcc|$(CC)|g' \
+ -e 's|-g|$(CFLAGS) $(LDFLAGS) |g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xmlindent || die "dobin failed"
+ doman *.1
+}