summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2021-05-12 22:54:36 +0200
committerSven Wegener <swegener@gentoo.org>2021-05-12 22:57:23 +0200
commit043d596a8a7bf060384714ab063f6b8313365430 (patch)
tree9e8f483d8f6b4dc1884b2e9c5e29aa16b5a62810 /dev-util
parenteclass/tests: eat optional arguments passed to has_version (diff)
downloadgentoo-043d596a8a7bf060384714ab063f6b8313365430.tar.gz
gentoo-043d596a8a7bf060384714ab063f6b8313365430.tar.bz2
gentoo-043d596a8a7bf060384714ab063f6b8313365430.zip
dev-util/systemtap: Version bump to 4.5
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/systemtap/Manifest1
-rw-r--r--dev-util/systemtap/systemtap-4.5.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-util/systemtap/Manifest b/dev-util/systemtap/Manifest
index 7a49d47e8939..e7cf61fc39b0 100644
--- a/dev-util/systemtap/Manifest
+++ b/dev-util/systemtap/Manifest
@@ -1,2 +1,3 @@
DIST systemtap-4.0.tar.gz 5282312 BLAKE2B 9eac1cf9c9f13255ac12642c910b5591b0f5380b2a6337dedcb3d20785c0416900b9bee05f239632f7c548812be35ae90b24f524ab6f5c0c6ef474cf5de834a1 SHA512 66b5ba1902ed974101429dce9fee849273d3dc64e862c057177d158c5f284cc93299819ee8ee49d4bd3b7ff47a3512b1c68b74cad374147ce67fa406c7518c79
DIST systemtap-4.4.tar.gz 5532282 BLAKE2B bcb2f744ad09821ce63d78b3e86eb489013aed247952c72d3dbc4cc6fc1a2b85f948b71c622487876f43b615c147eb1624b2c146e9b4176e3c91e2b7cbef9ea0 SHA512 8fb1fe5071ec99ce3c6bcf82afdc98a3e1abc0ea937f3019b225c3a1879ada30080740b1918a84c6db06fe1893e6d1e7dc84be26c7e597d7feda1efe11354e76
+DIST systemtap-4.5.tar.gz 5549909 BLAKE2B 3c180a49c81070cb374ae23f95f1e90cc3cf2550170363793f46584b201c2284b2ee639f395d73ed6c5b44160825b3cf128bd360b81bc243e71c98e71d779f48 SHA512 8136779a9f5cb0fbaae565eab1ab6fa307f1024dfc2c6c3845acfadff0eecc684ba89aa5d442c7b90c2c73edaab41ca07bae2bad8361f80fe8e9928b40466cd3
diff --git a/dev-util/systemtap/systemtap-4.5.ebuild b/dev-util/systemtap/systemtap-4.5.ebuild
new file mode 100644
index 000000000000..5a36994ebf65
--- /dev/null
+++ b/dev-util/systemtap/systemtap-4.5.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit linux-info python-single-r1
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="https://www.sourceware.org/systemtap/"
+SRC_URI="https://www.sourceware.org/${PN}/ftp/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="libvirt selinux sqlite +ssl test zeroconf"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/elfutils-0.142
+ dev-libs/json-c:=
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ ${PYTHON_DEPS}
+ libvirt? ( >=app-emulation/libvirt-1.0.2 )
+ selinux? ( sys-libs/libselinux )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ dev-libs/nspr
+ dev-libs/nss
+ )
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="${RDEPEND}
+ app-arch/cpio
+ app-text/xmlto
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ >=sys-devel/gettext-0.18.2
+ libvirt? ( dev-libs/libxml2 )
+"
+RDEPEND="${RDEPEND}
+ acct-group/stapdev
+ acct-group/stapsys
+ acct-group/stapusr
+"
+BDEPEND="test? ( dev-util/dejagnu )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1-ia64.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac \
+ Makefile.am \
+ stapbpf/Makefile.am \
+ stapdyn/Makefile.am \
+ staprun/Makefile.am \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docs
+ --disable-grapher
+ --disable-refdocs
+ --disable-server
+ --enable-pie
+ --with-python3
+ --without-java
+ --without-openssl
+ --without-python2-probes
+ --without-rpm
+ $(use_enable libvirt virt)
+ $(use_enable sqlite)
+ $(use_with zeroconf avahi)
+ $(use_with ssl nss)
+ $(use_with selinux)
+ )
+ PYTHON3="${PYTHON}" \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+}