summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 21:27:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:27 +0100
commit08c834a907e491d656d5191abd9ac09eedee2dfe (patch)
tree08170071749282a99e0a9e22fbddbc7cb8eb4c02 /dev-util
parentprofiles: mask libinput[doc] for riscv (diff)
downloadgentoo-08c834a907e491d656d5191abd9ac09eedee2dfe.tar.gz
gentoo-08c834a907e491d656d5191abd9ac09eedee2dfe.tar.bz2
gentoo-08c834a907e491d656d5191abd9ac09eedee2dfe.zip
dev-util/lxqt-build-tools: add version 0.8.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18140 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 31c4d9d8d4f6..1911e09ade44 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1 +1,2 @@
DIST lxqt-build-tools-0.7.0.tar.xz 24436 BLAKE2B b3bc9a62c530e682cff5412400d0fb14958d6aabddaef8c76b0073b01d356a9e7b227436428a3810f6b442dd77e57f4efb080a4902261679ad2c7898cf3098cb SHA512 7b6fd30e6ae8355ae36be55f8f7d47d78f507c11ebd9cbdd1d2ce5f14db68b845ad0bb8ca05fa1122bfd4c41f6dc792dff5100dcb8e61167517c3704527c7cde
+DIST lxqt-build-tools-0.8.0.tar.xz 25340 BLAKE2B c83524a5688cf38521406e50ad08e93b20d246c0fe779929905cd5aaff67ece6b7dae483d1d4f21657b913ab2ffc7ec821a3025ac6fe3585028146d1746f7565 SHA512 7c235df623ae8c88fa551f38bf24d0621958ce3586296a798b50bbce87084cb624298f4e5aaaa40d3244afae17b7fa373d2b8b6084377f9d7a355fc4bfcbb531
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild
new file mode 100644
index 000000000000..ce1e2b0aad19
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"