summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-29 15:47:28 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-29 16:45:18 -0500
commit157998864cb84db79ef1c53ae97e31b2c1085138 (patch)
tree663dca7a59c33bdabff62b99ea1be241b46b0db0 /dev-util
parentdev-util/buildbot-www: Version bump to 2.10.1 (diff)
downloadgentoo-157998864cb84db79ef1c53ae97e31b2c1085138.tar.gz
gentoo-157998864cb84db79ef1c53ae97e31b2c1085138.tar.bz2
gentoo-157998864cb84db79ef1c53ae97e31b2c1085138.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 2.10.1
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index ca1467cc7bca..d51ac1796f8c 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-wsgi-dashboards-2.10.0.tar.gz 5582 BLAKE2B 84b8ba49d967e40ab5cee28cac49d58ef97f794b07dff2eba5b27ddd712a4c34ae50d0b948f345fafe23549d1ab5d19aa0a5d799b6fb3eceb66591e70061cadd SHA512 15388a7acdacd22e8aa99e13f2a3bef75f097e64767751b246cdc5a72e19270928d61325217224cdb196eafffde0cda1dcc6a33d69cca5ef05f0d8b9836ccf72
+DIST buildbot-wsgi-dashboards-2.10.1.tar.gz 5590 BLAKE2B 3a138b7f150370d8ca63c0830985a4d0a85f0de45d33fe64e729c5e2df733468fe031fa54d6c794917eba91f53b87d7a479af30893e73c283d0fb208355fc90a SHA512 2b4ee561f7a4e10ecc26449035b4a49734caf46fc1207ac78a50cf34e7a52e928be548c6ea66f2ab2f7b1a53395b59cebdaa3a73308a780b4bdda8fad2b6e68e
DIST buildbot-wsgi-dashboards-2.8.2.tar.gz 5566 BLAKE2B 487b816862366acae9e55c39cb440a21c8e5c438299c43e2d6fad049ff946ece5ab647390955fbbad403ad1d7c0a2707a7612129442dc398cc7210d831aa49ef SHA512 2b75a61331aa457b3f168e1955b8905f95d11008ab6bee611ac92488f988cb0cf73fbf92321e594ac0a6e5ae03b82dfa05daab5a0647ae636a96922c0f4e8eff
DIST buildbot-wsgi-dashboards-2.8.4.tar.gz 5588 BLAKE2B 3298edaebe2f9eb5e31f8298598e892d64d653648843e3c107710d4df3a24977bd3e77db06f7edecdf8d85bbbdeedfc66a75c6f3eef93ec8374d0df1973790dc SHA512 656f0626c8cad2c21d64ebc3eb4d6e1ac24a10909afc28819e54046be8e843a7383f3648a00a908cfddd9543767e1c3293825170d7c6c64c40a61bdcd55245bd
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.1.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.1.ebuild
new file mode 100644
index 000000000000..6a3f2fda7faa
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"