summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-01-01 21:06:52 +0000
committerMike Gilbert <floppym@gentoo.org>2020-01-01 17:09:53 -0500
commit1dd235337ac96f0c1b5d87a84600576839e98e3e (patch)
tree6647121667279ea364b94bc4f22a9cc2bbe1035b /dev-util
parentdev-python/protobuf-python: Set DISTUTILS_USE_SETUPTOOLS="manual". (diff)
downloadgentoo-1dd235337ac96f0c1b5d87a84600576839e98e3e.tar.gz
gentoo-1dd235337ac96f0c1b5d87a84600576839e98e3e.tar.bz2
gentoo-1dd235337ac96f0c1b5d87a84600576839e98e3e.zip
dev-util/gyp: Use Python 3.
Bug: https://bugs.gentoo.org/695000 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gyp/gyp-99999999999999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-util/gyp/gyp-99999999999999.ebuild b/dev-util/gyp/gyp-99999999999999.ebuild
index 062dcc113759..da57f66635d9 100644
--- a/dev-util/gyp/gyp-99999999999999.ebuild
+++ b/dev-util/gyp/gyp-99999999999999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2017-2019 Gentoo Authors
+# Copyright 2017-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python2_7)
+PYTHON_COMPAT=(python{3_6,3_7})
DISTUTILS_SINGLE_IMPL="1"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
@@ -25,12 +26,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS=""
IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-BDEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND=""
DEPEND=""
-RDEPEND="${BDEPEND}"
+RDEPEND=""
src_test() {
# More errors when DeprecationWarnings enabled.