summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-30 23:28:03 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-12 23:21:30 +0200
commit2b3c55005c9f091855e14b49e5f6e340ae2a949c (patch)
treefd341b35b7c72e8e28f71b6f551dafabd182c893 /dev-util
parentllvm.eclass: Do not prepend /usr/bin to PATH, #622866 (diff)
downloadgentoo-2b3c55005c9f091855e14b49e5f6e340ae2a949c.tar.gz
gentoo-2b3c55005c9f091855e14b49e5f6e340ae2a949c.tar.bz2
gentoo-2b3c55005c9f091855e14b49e5f6e340ae2a949c.zip
dev-util/creduce: Require an LLVM slot with clang installed
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/creduce/creduce-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/creduce/creduce-9999.ebuild b/dev-util/creduce/creduce-9999.ebuild
index 34ca7641f734..b7accd15defa 100644
--- a/dev-util/creduce/creduce-9999.ebuild
+++ b/dev-util/creduce/creduce-9999.ebuild
@@ -6,7 +6,7 @@ EAPI="6"
EGIT_REPO_URI="https://github.com/csmith-project/${PN}"
: ${CMAKE_MAKEFILE_GENERATOR=ninja}
-inherit cmake-utils git-r3
+inherit cmake-utils git-r3 llvm
DESCRIPTION="C-Reduce - a plugin-based C program reducer"
HOMEPAGE="https://embed.cs.utah.edu/creduce/"
@@ -30,3 +30,7 @@ RDEPEND="${COMMON_DEPEND}
dev-util/astyle
dev-util/indent"
DEPEND="${COMMON_DEPEND}"
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}