summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2021-02-06 12:49:42 +0100
committerMatthias Schwarzott <zzam@gentoo.org>2021-02-06 12:50:05 +0100
commit3b3f18dac8785cc75a1a8c0c6940ca49c862aaaf (patch)
treeb6b99770c5e9a14514b87054fc5ddff92d5f6a5b /dev-util
parentapp-emulation/qemu: fix s/vis/via typo (diff)
downloadgentoo-3b3f18dac8785cc75a1a8c0c6940ca49c862aaaf.tar.gz
gentoo-3b3f18dac8785cc75a1a8c0c6940ca49c862aaaf.tar.bz2
gentoo-3b3f18dac8785cc75a1a8c0c6940ca49c862aaaf.zip
dev-util/dwarves: version bumped
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dwarves/Manifest1
-rw-r--r--dev-util/dwarves/dwarves-1.20.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/dwarves/Manifest b/dev-util/dwarves/Manifest
index 3f5bf203b020..31eef0ce4f51 100644
--- a/dev-util/dwarves/Manifest
+++ b/dev-util/dwarves/Manifest
@@ -1,3 +1,4 @@
DIST dwarves-1.17.tar.xz 309028 BLAKE2B 600d095359fa1ef208cc83655761505a07512faf9957144cc5fdd9e69bef98be3afc8b29a4c13aa0246aa43fdc9b4906de95f37c86fc6790ece52a79e3b13695 SHA512 8916ea24316efe1eb322d045fb2d81c230905f2fe33942eac641e9e0311f33a3bcf55be454eac32781799c255303bafacd8f1bd1b3ec08f0dae4d5f38d8186ba
DIST dwarves-1.18.tar.xz 324912 BLAKE2B bdce2903608a1229e2fc7e8a01bc41249a17a1a003fc3616910959fc43b430569cd737a220edfab2473485cd2dc0519b4add0e0e3a690e51ad35c4fa082752a5 SHA512 01647607ce0f4dfceb464367f2dd8a432f33eb5d0e003b6bbb07b38bd992a2992844309b04aee2a0388658c41d8b2059d03064c6e450fe7c347c5bca445d7938
DIST dwarves-1.19.tar.xz 686136 BLAKE2B f7fe50be30fa9b247bf0f35d5dec6aa8f1bed44eaaf8a2cde8da6f65a870212c2d257740a6d4f94da24f365ad49259d53c4f5447921b22754c63184001029620 SHA512 b378a504da5b00c6280b9efda7348c2d61015ce6477f3e4e4466f58d9bf6837457cd0aa9263b7d921093cca5ee26c4fab9950f7f75ca05d27ae646b3bfe22f9a
+DIST dwarves-1.20.tar.xz 688728 BLAKE2B c57f390f7e1d20c861a4acb8cd7fe238a3f7c3f2d915d96fc051dba2587942e8fabfa4f524d18555c486863fa02bc4ab63d90e90d477f376dc5e547aa36cccac SHA512 306bb74c498527a5a9bdae4d304e90511336cab627d9acad5237d93cbb48efe11dbca4418c540fa03e3ecdd168ce224cabe9fd2f6fbb50520d0dd17741c80817
diff --git a/dev-util/dwarves/dwarves-1.20.ebuild b/dev-util/dwarves/dwarves-1.20.ebuild
new file mode 100644
index 000000000000..f37545621fa9
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.20.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit multilib cmake python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang ostra/ostra-cg ostra/python/ostra.py
+}
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake_src_install
+}