summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-13 11:11:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-13 13:16:23 +0100
commit3fa2e6d1d4cc249c60178c81d3271911972967fa (patch)
treed5abb849424fd901123d8e84d6af674c667b4fa4 /dev-util
parentsci-libs/rtabmap: Remove old (diff)
downloadgentoo-3fa2e6d1d4cc249c60178c81d3271911972967fa.tar.gz
gentoo-3fa2e6d1d4cc249c60178c81d3271911972967fa.tar.bz2
gentoo-3fa2e6d1d4cc249c60178c81d3271911972967fa.zip
dev-util/wstool: bump to 0.1.17
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/wstool/Manifest1
-rw-r--r--dev-util/wstool/wstool-0.1.17.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index 1fabf6bf294a..db5883917c27 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1 +1,2 @@
DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
+DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
new file mode 100644
index 000000000000..5615dbd2b241
--- /dev/null
+++ b/dev-util/wstool/wstool-0.1.17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/wstool"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Commands to manage several local SCM repositories for ROS"
+HOMEPAGE="http://wiki.ros.org/wstool"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+PATCHES=( "${FILESDIR}/prefix2.patch" )
+DISTUTILS_IN_SOURCE_BUILD="yes"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ nosetests --with-coverage --cover-package=wstool || die
+}