summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-10-01 16:25:39 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-10-01 16:26:02 -0600
commit523a9ececb4bb72e05c70ad2d73fe6514e8ada21 (patch)
tree1709cae74ccd2172c1f42b25fb0789e98223d566 /dev-util
parentdev-java/jss: Version bump to 4.3.2 (diff)
downloadgentoo-523a9ececb4bb72e05c70ad2d73fe6514e8ada21.tar.gz
gentoo-523a9ececb4bb72e05c70ad2d73fe6514e8ada21.tar.bz2
gentoo-523a9ececb4bb72e05c70ad2d73fe6514e8ada21.zip
version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cwdiff/Manifest1
-rw-r--r--dev-util/cwdiff/cwdiff-0.3.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/cwdiff/Manifest b/dev-util/cwdiff/Manifest
index 004e7097a936..de1261608a36 100644
--- a/dev-util/cwdiff/Manifest
+++ b/dev-util/cwdiff/Manifest
@@ -1,2 +1,3 @@
DIST cwdiff-0.2.8.tar.gz 4246 SHA256 cdfd1489420591b36a56370c647b361f87c0c4074fed220e9c09f3e7ea8f2c22 SHA512 bb1fb3790cc2d8f4e5f199e7abc9bf6a999ded0d25fc9e62ca1e003505f1d33b6c8575b0172a2e55128c4e5c853147304c928d0f1094c5b30e6a015b9fbcae09 WHIRLPOOL 7dec074fa079bb1468179efe6f559010b2d8267343ea5c77ad72810301baf49cb63977c7617bdc41321c944fdd067c6202d8a87b6bd5200f561176fac2fc115a
DIST cwdiff-0.3.0.tar.gz 4666 SHA256 32c70aeae4e445a439aeed7f9b01395cc74645033533cc37b6974671cf2cfd9b SHA512 40401a0541209c83cd78ff55c62ce71dd362cf8674b07c1cdd56ad7a505741e818003f07c87fe0303cd2bfd911d99b8f560697612b32b6fee794a7671e7e86f0 WHIRLPOOL aad2e3c5c6d8dc94f70c8b272969598bf134f73bc0fc030d5f4087d341a2074736e5b409afc99c8039f250c2f0154b22d86b153e7ac3e4edc12f4c0642be2e76
+DIST cwdiff-0.3.1.tar.gz 4706 SHA256 c2b7d3a1ba7b6efae217f82773dbfc36a6bda862957ef69c67b2bcfa718c5909 SHA512 ffea1f699d333655eebfe96048dcc96c57408d42915d707e10b9231a27cc7a8803c3b47876227e24da67376ec18f9261739b9fb13889f8b47d336ca048cbfa72 WHIRLPOOL 83e8eb2cd9cf4647c54ecf6306e5f030c7760c8d1ece3fd588805b2b6cf7a302ef58078da176d2ffe1dbb4613d49572c3d7f5765d4e74aeba7599cf9dfa60c2d
diff --git a/dev-util/cwdiff/cwdiff-0.3.1.ebuild b/dev-util/cwdiff/cwdiff-0.3.1.ebuild
new file mode 100644
index 000000000000..eaf721e87f4a
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="a2ps mercurial"
+
+DEPEND="sys-apps/help2man
+ sys-apps/coreutils"
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install() {
+ emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
+ dodoc README.md
+}