summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-16 13:59:43 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-16 14:00:47 +0100
commit57dfa51ed5fc60a53c0c3a8a44d891eadd586b89 (patch)
treefc5d6900be9a5bdf65bf980981784fbf229c9d8e /dev-util
parentmedia-plugins/imlib2_loaders: version bump (diff)
downloadgentoo-57dfa51ed5fc60a53c0c3a8a44d891eadd586b89.tar.gz
gentoo-57dfa51ed5fc60a53c0c3a8a44d891eadd586b89.tar.bz2
gentoo-57dfa51ed5fc60a53c0c3a8a44d891eadd586b89.zip
dev-util/cppunit: Bump to version 1.15.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppunit/Manifest1
-rw-r--r--dev-util/cppunit/cppunit-1.15.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/cppunit/Manifest b/dev-util/cppunit/Manifest
index 624a7099190e..b3d6502bfd91 100644
--- a/dev-util/cppunit/Manifest
+++ b/dev-util/cppunit/Manifest
@@ -1 +1,2 @@
DIST cppunit-1.14.0.tar.gz 959716 BLAKE2B 581e3b73d6d152c249005ddf267100443e6c9cba12c52c43e9d6f81096b9cd13c3686fa2f73ebaf28c31193e41dbfd5d919dfb0143b190881345da65a5b7f86d SHA512 4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e
+DIST cppunit-1.15.1.tar.gz 814363 BLAKE2B a1d1d1ee9b6ef408843a6e989a37653944ad85069b4896f18d0f01410acebf7342f70e8c031e58f7ad0e686a85869d521906816e0f0b1762d238efb606cb7310 SHA512 0feb47faec451357bb4c4e287efa17bb60fd3ad966d5350e9f25b414aaab79e94921024b0c0497672f8d3eeb22a599213d2d71d9e1d28b243b3e37f3a9a43691
diff --git a/dev-util/cppunit/cppunit-1.15.1.ebuild b/dev-util/cppunit/cppunit-1.15.1.ebuild
new file mode 100644
index 000000000000..a03be99e2df6
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.15.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )
+"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
+
+src_prepare() {
+ default
+ [[ "${PV}" == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
+ fi
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}