summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-09-22 19:13:07 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-09-22 20:00:27 -0700
commit5f418ec97507e046cbcc46e1fa5b4195b8b6d25c (patch)
treed529ff943ab474889e6776e05888cd1f12618c97 /dev-util
parentdev-util/buildbot-waterfall-view: Version bump to 3.6.1 (diff)
downloadgentoo-5f418ec97507e046cbcc46e1fa5b4195b8b6d25c.tar.gz
gentoo-5f418ec97507e046cbcc46e1fa5b4195b8b6d25c.tar.bz2
gentoo-5f418ec97507e046cbcc46e1fa5b4195b8b6d25c.zip
dev-util/buildbot-wsgi-dashboards: Version bump to 3.6.1
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index e677fd23fdb7..ff13d27b3231 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-wsgi-dashboards-3.4.0.tar.gz 5583 BLAKE2B 0eed4a375330d58bd6caf95f8cdc2ebfaebc9c123450461d4e0f938745bb1b6afe0e9786bd886c6e6cb6a522da2b645bf1ad3237b2049f86bc1bca83829b15a1 SHA512 56411bb34a1f40d02a814e8d33dcd3c6de65627728c3bb9cad776c43c48707e648ccdbb4a58cbfb8ed080c219fc37252304c88ab363eb6deb6057b2debde1071
DIST buildbot-wsgi-dashboards-3.5.0.tar.gz 5585 BLAKE2B 94c365d4140de539a0ea85b78e24acd5d789fe022eb5ff2474ebc07554d139d964c9625b684b312b2134c3fd4bf3a6628178ac72d52283bb6fcfd7b7820d51f1 SHA512 d233273c05f9c2f6d81091dd620469dd19377848d5958c26cc746b6340ea9451c49aff8f8a36986741b3775fcc60065e0fbc402183f60f43d4afce238b907fd0
DIST buildbot-wsgi-dashboards-3.6.0.tar.gz 5585 BLAKE2B 91de620cdb911b75ad745549e6fa7d1589206d8b17878b1779b40b84633dc9788d3dca46a34866c40d2403ed1a16c20d6159d0f0ce69d3e10f35d132cba06f35 SHA512 8377ef27f46b65ebb5e5dc638cab0e251070b940386b4681ea410562e6eaef04d4a76bfd3be229c081edb2f9df01c1385aad34a7763dcd5ce607fb0061b741e4
+DIST buildbot-wsgi-dashboards-3.6.1.tar.gz 5584 BLAKE2B f0b82de52022c3a8a0d0747aa4ade67345af177be70a8767d66163fe98ceff63e0b297ba547619de874a66e381b721c48d864361fdb82a818f2450c339d687cc SHA512 7ecd4fd71786258deab1fb1d96b4999ef929df4486d09404cb1bc3d1a7f831c90f8253f5bf0474258ba472ac9e8f960f4c4eb1f7993a0a8070eaa68e3bbbb4e9
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
new file mode 100644
index 000000000000..b67bfb3e65bf
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"