summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-03 13:48:22 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-03 13:48:22 +0100
commit629440159c050c2e050d2429823e5062ae7fc0be (patch)
tree20edfa8bd670117ae0382b4749c2eb3a4fd787b5 /dev-util
parentsys-boot/systemrescuecd-x86-grub: Merge new package (diff)
parentdev-util/ctags: add a snapshot ebuild (diff)
downloadgentoo-629440159c050c2e050d2429823e5062ae7fc0be.tar.gz
gentoo-629440159c050c2e050d2429823e5062ae7fc0be.tar.bz2
gentoo-629440159c050c2e050d2429823e5062ae7fc0be.zip
dev-util/ctags: Merge "add a snapshot ebuild"
Pull-Request: https://github.com/gentoo/gentoo/pull/286
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ctags/Manifest1
-rw-r--r--dev-util/ctags/ctags-5.8_p20140919.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/ctags/Manifest b/dev-util/ctags/Manifest
index 92c894834698..53e165ada1c6 100644
--- a/dev-util/ctags/Manifest
+++ b/dev-util/ctags/Manifest
@@ -1,2 +1,3 @@
DIST ctags-5.8.tar.gz 479927 SHA256 0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7 SHA512 981912cd335978cde22864e977947fc75326572fb29518e559cc4a8ac1edc84b3604165218a666e36353f17da4f89f8e967acdb88696f816748eb946d79eaa15 WHIRLPOOL 04506a4495025907ee5fe41b9c4ff104dd234fc9ef39bd594158b36c550bf511b6ab5980a98736f9857dc47b99f1718a7ae2928fd4a1d1c0b57dfd3d79fce2ea
+DIST ctags-5.8_p20140919.tar.gz 582289 SHA256 eebc85bd0206988250d9b24a7d02918bbca751259b086d5f53f31b4b39f571ee SHA512 3b6ad6e2d1f683dffe9e79c607f9cc222c4aa3c1f5113540cd18ea66d8f862917c9d849ee81d8b33a57ddd09749fa28fde74868d48479269a6e17b6c0451342d WHIRLPOOL 0c4008e914aed33097641fbb517f33e2ccf771a968ae3d1f6288422cdb634dda054ece11dd6204d624c9c78d4a36cecc4bb9d696d07f2bba24f3099aa3758f48
DIST ctags-ada-mode-4.3.11.tar.bz2 14060 SHA256 d25a3fd26b356adbd068f10a0b68691d36c154c04b96304b96386e169e4b6b57 SHA512 51c71e13ef658cd6682f04c94485315c4a702080ef2c7786fc9881b03c86f1c1d43aa1a69c452e4b0b2f7a78383804b66b159542cb4eae0cd309bc1ddbe2eb6e WHIRLPOOL 7e0ded8c97d3651e1afe48ec836697a4a19264baf3b203f6e98c134b88e3ab0eee7ac660789f5b955f0f827128996988694aa6c4bc78f18adf52724c5230da5d
diff --git a/dev-util/ctags/ctags-5.8_p20140919.ebuild b/dev-util/ctags/ctags-5.8_p20140919.ebuild
new file mode 100644
index 000000000000..fbb97bbd5bdf
--- /dev/null
+++ b/dev-util/ctags/ctags-5.8_p20140919.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools vcs-snapshot
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+# this commit is from the sourceforge branch, which is a git-svn clone of the
+# original exhuberant-ctags SVN repository
+SRC_URI="https://github.com/universal-ctags/ctags/archive/9fce9dd0afd3dd261c681825a61d3e9ffcaa7eea.tar.gz -> ${P}.tar.gz
+ ada? ( mirror://sourceforge/gnuada/ctags-ada-mode-4.3.11.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ada"
+
+RDEPEND="app-eselect/eselect-ctags"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.6-ebuilds.patch"
+
+ # Bug #273697
+ epatch "${FILESDIR}/${PN}-5.8-f95-pointers.patch"
+
+ # enabling Ada support
+ if use ada ; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}" || die
+ epatch "${FILESDIR}/${PN}-5.8-ada.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp
+}
+
+src_install() {
+ emake prefix="${D}"/usr mandir="${D}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+
+ dodoc FAQ NEWS README EXTENDING.html
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}