summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-19 10:36:18 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-04-29 10:12:58 +0300
commit6de73fe347f9b670f78688872ff6ed5b805efe93 (patch)
tree86f31920902c35f96a704919160e9b119cccdb27 /dev-util
parentdev-cpp/notcurses: add missing die (diff)
downloadgentoo-6de73fe347f9b670f78688872ff6ed5b805efe93.tar.gz
gentoo-6de73fe347f9b670f78688872ff6ed5b805efe93.tar.bz2
gentoo-6de73fe347f9b670f78688872ff6ed5b805efe93.zip
dev-util/rebar-bin: Bump to 3.15.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rebar-bin/Manifest1
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.15.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
index 7eb3713de2cd..7426f864f422 100644
--- a/dev-util/rebar-bin/Manifest
+++ b/dev-util/rebar-bin/Manifest
@@ -1 +1,2 @@
DIST rebar-bin-3.14.4 943940 BLAKE2B b9196c44407783f5cdeec6d56acad20837b2f9c550e5dd1cc16d7190a5dd9897cf4044720175db216f154beed093fc81b4a3c26702e7f4675473924dc7508530 SHA512 35a8ca34a26c7fe0b7edc22ca0589b3813827ee6d59f49e7b2669186fc6183d4efd33c258a4659f14421bbe2b2d7c7c464ab7fd36f87297faa3c6f812945eb2d
+DIST rebar-bin-3.15.1 951017 BLAKE2B b9c71729397678ace6b9988dc3bbcf3685a9c832298f66ac8b758f515c7c4f0e24b5bebaea93fa7f2f1b1fd88cebd7581c6e2c7e6efc08b5138225b1a02700d8 SHA512 3dd66d3e35b4431a9cc565a20ebdad9732df6e673b818236be5be377279b179ddf12c953268b0d6edf5f0c45253b4e5a0b192904f1c606354dbed2ae86fb2403
diff --git a/dev-util/rebar-bin/rebar-bin-3.15.1.ebuild b/dev-util/rebar-bin/rebar-bin-3.15.1.ebuild
new file mode 100644
index 000000000000..a483e583b864
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.15.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}