summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-02-12 19:33:28 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-02-12 19:38:37 +0100
commit7530cbd74c782790395e8f627a94cdb0d2fac116 (patch)
treefda3f723bc7d2da0ae075318ba7d1f41b439a30a /dev-util
parentapp-text/doconce: initial import (diff)
downloadgentoo-7530cbd74c782790395e8f627a94cdb0d2fac116.tar.gz
gentoo-7530cbd74c782790395e8f627a94cdb0d2fac116.tar.bz2
gentoo-7530cbd74c782790395e8f627a94cdb0d2fac116.zip
dev-util/rr: add seccomp requirement
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rr/rr-4.5.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/rr/rr-4.5.0.ebuild b/dev-util/rr/rr-4.5.0.ebuild
index 09413354976f..4ad1d8612c20 100644
--- a/dev-util/rr/rr-4.5.0.ebuild
+++ b/dev-util/rr/rr-4.5.0.ebuild
@@ -7,7 +7,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
CMAKE_BUILD_TYPE=Release
-inherit cmake-utils python-single-r1
+inherit cmake-utils linux-info python-single-r1
DESCRIPTION="Record and Replay Framework"
HOMEPAGE="http://rr-project.org/"
@@ -28,5 +28,9 @@ RDEPEND="
${DEPEND}"
pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="SECCOMP"
+ linux-info_pkg_setup
+ fi
python-single-r1_pkg_setup
}