summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2018-12-28 02:04:42 +0000
committerMichał Górny <mgorny@gentoo.org>2019-04-29 14:28:20 +0200
commit75875502e51e8b8eaa61674d9e8456c61098339b (patch)
treea6318ec93e43d46c06d60edc277269d7ba27b93a /dev-util
parentdev-util/flawfinder: add maintainer to metadata.xml file. (diff)
downloadgentoo-75875502e51e8b8eaa61674d9e8456c61098339b.tar.gz
gentoo-75875502e51e8b8eaa61674d9e8456c61098339b.tar.bz2
gentoo-75875502e51e8b8eaa61674d9e8456c61098339b.zip
dev-util/flawfinder: bump to 2.0.7
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/10699 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/flawfinder/Manifest1
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/flawfinder/Manifest b/dev-util/flawfinder/Manifest
index 310f9031d17e..e101b3d26a07 100644
--- a/dev-util/flawfinder/Manifest
+++ b/dev-util/flawfinder/Manifest
@@ -1 +1,2 @@
DIST flawfinder-1.31.tar.gz 174148 BLAKE2B f545a9d4dc8c0a9d7ae34fb5b26e06eb7c40a916155fdd738e4d56b6fccee4af1941935b6847d5f6c8f968ba45e95a8e9b44e5723b11a9c47fce725d1c27dcf1 SHA512 880919a05dbf0e29055f052b88c8bbfd403105504749bc65fb17675e6ebe0d84f9cd367e7a6efc68dc0d9209e0938185da4718b70f484007c507fe96b83e0355
+DIST flawfinder-2.0.7.tar.gz 249177 BLAKE2B 35dc5796ca7ecf456bf623247c7fb3944e05864bb714900a386f3e39eed81695409b44b9684365e4b172feb938a7c781c831856a8a94826c48b1027698b0967a SHA512 ecfe98c58e253b1d90b833747d69c41597ab7b4c82286e5f45dff45de90056216c25d2c9626540aebfc1e475882a04c3cfa3c0cb3ee242f498f5cdfe188d761f
diff --git a/dev-util/flawfinder/flawfinder-2.0.7.ebuild b/dev-util/flawfinder/flawfinder-2.0.7.ebuild
new file mode 100644
index 000000000000..773f6f36ef09
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="https://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+src_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}