summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 12:49:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:44 +0200
commit78f6ca6ca6a17e3120d961bcbd81c4a0d5bf8475 (patch)
treee7466043c666742c221b732d91c4da3c45ca81eb /dev-util
parentdev-ros/pcl_ros: add upstream patch for new pcl (diff)
downloadgentoo-78f6ca6ca6a17e3120d961bcbd81c4a0d5bf8475.tar.gz
gentoo-78f6ca6ca6a17e3120d961bcbd81c4a0d5bf8475.tar.bz2
gentoo-78f6ca6ca6a17e3120d961bcbd81c4a0d5bf8475.zip
dev-util/catkin: bump to 0.8.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catkin/Manifest2
-rw-r--r--dev-util/catkin/catkin-0.8.10.ebuild (renamed from dev-util/catkin/catkin-0.8.9.ebuild)15
-rw-r--r--dev-util/catkin/catkin-9999.ebuild15
3 files changed, 5 insertions, 27 deletions
diff --git a/dev-util/catkin/Manifest b/dev-util/catkin/Manifest
index cd13737b5834..eae184335c26 100644
--- a/dev-util/catkin/Manifest
+++ b/dev-util/catkin/Manifest
@@ -1 +1 @@
-DIST catkin-0.8.9.tar.gz 217743 BLAKE2B e59df77a7df04492942917377f4f3dd9e302e20fd901bbc8878d1f51879a481e15b01482db4f1d3b8d1eee360779bedb5d999663fe58f10d33c5e4f1964a3be7 SHA512 a34784d349935f5917e7d4600c5ad3e728a86d8ed235fb3be86b4dec212693a1e4209901929d284e50c112f31ada62a04a9caf9845ee06c6db2e98e79602ecd9
+DIST catkin-0.8.10.tar.gz 218095 BLAKE2B cac62d7682e14e258cb7b8a55ae93c8792dcdb38b281c68b8135adfe9225c07a0c6c16717426f9b12ccc6aba91178cf18eeb05a0474ee6524131970e0c158c92 SHA512 0bab7a7b13484b09d301af52f7e563b78d8b80ac5cfc36a36a725baea7f23bf374d4814303875a4a1aa3981e346a3e5fa3f9b1e27c3ae819102dbc239ca767b1
diff --git a/dev-util/catkin/catkin-0.8.9.ebuild b/dev-util/catkin/catkin-0.8.10.ebuild
index 65304103f95e..1918b71d47c2 100644
--- a/dev-util/catkin/catkin-0.8.9.ebuild
+++ b/dev-util/catkin/catkin-0.8.10.ebuild
@@ -67,8 +67,7 @@ catkin_src_configure_internal() {
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
)
- python_export PYTHON_SCRIPTDIR
- cmake_src_configure
+ PYTHON_SCRIPTDIR="$(python_get_scriptdir)" cmake_src_configure
}
src_configure() {
@@ -85,12 +84,11 @@ src_compile() {
}
src_test() {
- unset PYTHON_SCRIPTDIR
python_foreach_impl cmake_src_test
}
catkin_src_install_internal() {
- python_export PYTHON_SCRIPTDIR
+ export PYTHON_SCRIPTDIR="$(python_get_scriptdir)"
cmake_src_install
if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
dodir /usr/bin
@@ -111,12 +109,3 @@ src_install() {
python_foreach_impl python_optimize
}
-
-pkg_postinst() {
- ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
- ewarn "installation path for package.xml files on Gentoo."
- ewarn "In order for ROS to work properly, you will need to reinstall ROS"
- ewarn "packages that have it installed in the old location:"
- ewarn " emerge -1O /usr/share/*/package.xml"
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
-}
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index 65304103f95e..1918b71d47c2 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -67,8 +67,7 @@ catkin_src_configure_internal() {
-DPYTHON_EXECUTABLE="${PYTHON}"
-DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
)
- python_export PYTHON_SCRIPTDIR
- cmake_src_configure
+ PYTHON_SCRIPTDIR="$(python_get_scriptdir)" cmake_src_configure
}
src_configure() {
@@ -85,12 +84,11 @@ src_compile() {
}
src_test() {
- unset PYTHON_SCRIPTDIR
python_foreach_impl cmake_src_test
}
catkin_src_install_internal() {
- python_export PYTHON_SCRIPTDIR
+ export PYTHON_SCRIPTDIR="$(python_get_scriptdir)"
cmake_src_install
if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
dodir /usr/bin
@@ -111,12 +109,3 @@ src_install() {
python_foreach_impl python_optimize
}
-
-pkg_postinst() {
- ewarn "Starting from version 0.7.1-r2, dev-util/catkin changed the"
- ewarn "installation path for package.xml files on Gentoo."
- ewarn "In order for ROS to work properly, you will need to reinstall ROS"
- ewarn "packages that have it installed in the old location:"
- ewarn " emerge -1O /usr/share/*/package.xml"
- ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=595004 for more details."
-}