summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-01 04:17:21 +0100
committerJeroen Roovers <jer@gentoo.org>2016-03-01 04:21:27 +0100
commit7c8490a45dbde3fedffc45f365209af8a6c137fd (patch)
treef8207e0df651d09522c61b323f4a7a053540e416 /dev-util
parentdev-util/dialog: Old. (diff)
downloadgentoo-7c8490a45dbde3fedffc45f365209af8a6c137fd.tar.gz
gentoo-7c8490a45dbde3fedffc45f365209af8a6c137fd.tar.bz2
gentoo-7c8490a45dbde3fedffc45f365209af8a6c137fd.zip
dev-util/dialog: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dialog/Manifest1
-rw-r--r--dev-util/dialog/dialog-1.3.20160209.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index 374b5a2212b8..b8a36fc4e1af 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1 +1,2 @@
DIST dialog-1.2-20150920.tgz 498181 SHA256 c4e61ec5768701683dd4b5b2ebd8a31e6289fa6a1f5801e4b481085650698c05 SHA512 9cc0005ef6a0d7dc0b8263a433b0955fd8331fec9bceb0676dfb17da566d73216a089eab85b804918017623b98653bdb6b4e809a99ecf638f5a529dcf6314e48 WHIRLPOOL 7387fe72b56b20850826506b844e3d4378e7287aa67fc04b3f72d5684b34229fa14351ec2b8542c72b8a303c7c9819b8ead699575ad8eb90707d5e10de077e07
+DIST dialog-1.3-20160209.tgz 499300 SHA256 0314f7f2195edc58e7567a024dc1d658c2f8ea732796d8fa4b4927df49803f87 SHA512 77ad7698c8acc9ec2c4a8e76d73972ed3ee8d323cdb8cb18fbe496ebe4a6c8be873e0e2ecf66bbeb7eb6c398d0ca125969cb068e89c33a17521e1e1b913b1e4a WHIRLPOOL 7faf2cb0c01bd314af61d1d180d78232ba57fbb5985f18365256888e29430d3bd8c65de38a5d51045e0fd05bd72d84cf7869ed86aa9bc37fb73ff64c2a795c30
diff --git a/dev-util/dialog/dialog-1.3.20160209.ebuild b/dev-util/dialog/dialog-1.3.20160209.ebuild
new file mode 100644
index 000000000000..8dd6e904b47b
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20160209.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib versionator
+
+MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+
+src_prepare() {
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}