summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:08:57 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:19:30 -0400
commit802c98a06f4ee15a4d3c1c05775a616c2dbe0e77 (patch)
tree2b4f59b89dd0a4caf0f629c7ad09b03c44557d52 /dev-util
parentdev-util/buildbot-waterfall-view: Version bump to 3.1.1 (diff)
downloadgentoo-802c98a06f4ee15a4d3c1c05775a616c2dbe0e77.tar.gz
gentoo-802c98a06f4ee15a4d3c1c05775a616c2dbe0e77.tar.bz2
gentoo-802c98a06f4ee15a4d3c1c05775a616c2dbe0e77.zip
dev-util/buildbot-console-view: Version bump to 3.1.1
sync KEYWORDS among the pkgs. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-3.1.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index d23f3b25d353..20e060d79698 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -4,3 +4,4 @@ DIST buildbot-console-view-2.8.2.tar.gz 17575 BLAKE2B e036429dd40fdfdadd65a10d4f
DIST buildbot-console-view-2.8.4.tar.gz 18531 BLAKE2B 8d997e34eefea4be6bbbb33902b992a4864b601ef689cedbd7051667e5cab1ee45b13e2d5ad888af4a805ab1a60f0bc79439580583b3c3e233d321b52b28e0d9 SHA512 ccaa8b9ab18bd6e6609ab017ce4f2d447f99310b3448584decb8a572c573426bf84e6b86837f68b715863c66de013a8cad546e35dbbfb051c1c8d32a3825fe7f
DIST buildbot-console-view-3.0.2.tar.gz 18724 BLAKE2B bc8a75ba284547c5d9c71094f0780242198be14d0e86da2ee837c3437e8e4c76212d4c8ebafb9e6042a8fc8a35530e6fa0df95890ab6fe592d295de2b74df1ba SHA512 15e80c4036c5451a1a48d2d7254118586c4a97ea49d06d04a1237f1c82bdf8b3c044235c7b1cfa46cf892168e94becd48cd4d376479abd8212dbfc0662b7cecc
DIST buildbot-console-view-3.1.0.tar.gz 18730 BLAKE2B 61703292ddff90e096cd70a5f1001d0e521884f1e89936ca0f11c917867224ac60d61fe96a6f24a51cdfd4b40bb052443a839a51a8849cb76bb93b938a0272c9 SHA512 88b568ec2a7457b074e7448671991e907d52bcf5b1298d37f6b567b9e5ffc98b82ee1f0d9aed3a5841904d482476502f88aca31b93e505b5ea8db56d8b8f882f
+DIST buildbot-console-view-3.1.1.tar.gz 18731 BLAKE2B 266e08a04f5c6e618c101d5c7fcfaf08b7ad389346bce94f5e6e2a9cc3eb65906228c0ad12503a0ef1beb330b2f16ff3a532ac9861443018b7a5eb4c85488d64 SHA512 6287643f320a06bd56b8826fbca665a5a2d5bc0914c0dfd7b01fe273ce3220fd89a0267ed4bed979393b87d5a48fa53df579acc4df965be12f87eab43584eae5
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-3.1.1.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-3.1.1.ebuild
new file mode 100644
index 000000000000..251b0b05b8c9
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-3.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}