summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-04-30 15:54:04 +0100
committerMarek Szuba <marecki@gentoo.org>2019-05-01 17:51:33 +0100
commit8064dd92a637ddc882ce7e5beaf229618ab478f2 (patch)
treefd23e2cca408135fd46f0dffdd820badcfd51252 /dev-util
parentdev-libs/opencl-clang: new package (diff)
downloadgentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.tar.gz
gentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.tar.bz2
gentoo-8064dd92a637ddc882ce7e5beaf229618ab478f2.zip
dev-util/intel-graphics-compiler: new package
First-order dependency of Intel Graphics Compute Runtime. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild35
-rw-r--r--dev-util/intel-graphics-compiler/metadata.xml12
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
new file mode 100644
index 000000000000..74cb134a495d
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -0,0 +1 @@
+DIST intel-graphics-compiler-1.0.3.tar.gz 6721202 BLAKE2B 2934778e931a4b38a239ede5944757cc42c0a965e700ba471272ba8e9ca08b1c1c790c920ed6896a870985b1d2819a182a9aaf5a5a8cbfc13038ecd7cf1def1e SHA512 c0c0cc21263b71bc57aed43a3e8bd641ea7853db0a574823a70abb592a69b7f8a9f426e88e7fddea4cf6a14de44e064f80abcfa3ea709701e5003e0d4b7adfb0
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild
new file mode 100644
index 000000000000..b15c94ceace5
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ dev-libs/opencl-clang:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCCLANG_BUILD_INTREE_LLVM=OFF
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix)/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ # Until a new official release of opencl-clang
+ -DCOMMON_CLANG_LIBRARY_NAME=common_clang
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-util/intel-graphics-compiler/metadata.xml b/dev-util/intel-graphics-compiler/metadata.xml
new file mode 100644
index 000000000000..b124b9c53046
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/intel-graphics-compiler</remote-id>
+ </upstream>
+</pkgmetadata>
+