summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-03-26 21:49:24 -0400
committerCraig Andrews <candrews@gentoo.org>2018-03-26 21:51:24 -0400
commit8f03586a73a35d48799d53d255f64df028586eeb (patch)
tree1d003d8de81e23533bfa5db919a1dd0fd8ec519d /dev-util
parentlxde-base/lxpanel: RDEPEND x11-libs/gdk-pixbuf[X] (diff)
downloadgentoo-8f03586a73a35d48799d53d255f64df028586eeb.tar.gz
gentoo-8f03586a73a35d48799d53d255f64df028586eeb.tar.bz2
gentoo-8f03586a73a35d48799d53d255f64df028586eeb.zip
dev-util/clinfo: 2.2.18.03.26 version bump
Add dependency on >=app-eselect/eselect-opencl-1.1.0-r4 to ensure the required opencl 2.0 headers are present. Closes: https://bugs.gentoo.org/650730 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/clinfo/Manifest1
-rw-r--r--dev-util/clinfo/clinfo-2.2.18.03.26.ebuild26
-rw-r--r--dev-util/clinfo/clinfo-9999.ebuild5
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-util/clinfo/Manifest b/dev-util/clinfo/Manifest
index 6e9bb1adb20b..8e32958ec6f9 100644
--- a/dev-util/clinfo/Manifest
+++ b/dev-util/clinfo/Manifest
@@ -1,3 +1,4 @@
DIST clinfo-2.2.17.10.25.tar.gz 32992 BLAKE2B aedc6c48e557ca1222caa207a1e916f3d8e2d3666379c25dc8f28bfdbc74fee0d0918d0e5a84fd830a99cb5f09cbe452ed9329d44706783277d70600dcdd5c76 SHA512 9b035fb9ee052a8cff517032db70d16c796c3a2b82fefded5805dd7b012472b1226fc634d8b9e890be604f26f959a2a7438966158e2ccfc9e27af1fc03971c46
DIST clinfo-2.2.18.03.15.tar.gz 35465 BLAKE2B f6a713b8e1af7ad048335409996143697f7bfea742bab979a7999a02fbbdb83f744dd4fc636877d083028177210a9b13012af0c8b47fc676b7711fb5d3d1e7dd SHA512 fb0a38d14c9416dd82df4f44e6f66ded7156211f0ad65c9ac141df8d0d1e80bc003e5ee9a2206925a40b89fe278a1c6bd2880805dac745947f0ef324d5edb885
DIST clinfo-2.2.18.03.22.tar.gz 37210 BLAKE2B 394ffa3f5fbd0704c412053fbe7591fa629bae749b8235ba53baadccab244d09500bc648e91ee97b7fe5dec2472a209a5c788a17d8a1e7f908829eb628b9b699 SHA512 c31f700be8d1860301b7c1b6ed76964e9e0252f055ff5c1abd1875bd553591bed2c81e6a2be6fa0ac82d49609e9651944cdfedf584beef2384679975221f0f8c
+DIST clinfo-2.2.18.03.26.tar.gz 38519 BLAKE2B 736036f4f84c170876b9b550bfe837c67a273cef9032af8734035edf5070d17d876d10f7d5c81889966df0a9ad4192c43c1501326188782cc674611ea57130ef SHA512 dec90a314e6c52e5501339dbe594cb57cfc8cae6855db7bb88b36984fd661e55f2cc8eb29fa546998862c806ec752bfc2b6a9e0d9d962370f84b0091605c1bcb
diff --git a/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild b/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
new file mode 100644
index 000000000000..3d01e885bdad
--- /dev/null
+++ b/dev-util/clinfo/clinfo-2.2.18.03.26.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}
diff --git a/dev-util/clinfo/clinfo-9999.ebuild b/dev-util/clinfo/clinfo-9999.ebuild
index a3dd2fa351bc..3d01e885bdad 100644
--- a/dev-util/clinfo/clinfo-9999.ebuild
+++ b/dev-util/clinfo/clinfo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,8 @@ HOMEPAGE="https://github.com/Oblomov/clinfo"
LICENSE="CC0-1.0"
SLOT="0"
-DEPEND="virtual/opencl"
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+ virtual/opencl"
RDEPEND="${DEPEND}"
src_install() {