summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-27 15:53:23 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-27 15:58:59 +0100
commit958fd1ca81b81118a0e2226c4c4914f8bddc7765 (patch)
treebe5208cad5dde53b14e57a874b68d017f3cbcfb7 /dev-util
parentdev-util/debhelper: Old (diff)
downloadgentoo-958fd1ca81b81118a0e2226c4c4914f8bddc7765.tar.gz
gentoo-958fd1ca81b81118a0e2226c4c4914f8bddc7765.tar.bz2
gentoo-958fd1ca81b81118a0e2226c4c4914f8bddc7765.zip
dev-util/debootstrap: Version 1.0.112
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.112.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index ef842e30f330..1ca567f2012d 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,5 @@
DIST debootstrap_1.0.110.tar.gz 74847 BLAKE2B fe715bf7657aebfab40f4196f69c29ee0a3ee5c882e1618645cebb30e792a8bc5db3c0cbc7b0978b89462f1109a1257c9702260471f4d9c8231062f1947123b4 SHA512 5c89887073d1ddd06eeeb57cf36c908ae5a4094cafbbab1ea6cade376f6babc9bf6c981989a2a1b9b5da89f1ab8096b7283d3d7565a1d90af0174095d93f2a7f
DIST debootstrap_1.0.111.tar.gz 75503 BLAKE2B 96489f3ea8af07b00c685b7454ea255354ea8c08e01ded40a14e9431287c6b7f347cb0960107588ecb583ddac675dd0cb92cfb876d08f91436e0015bbd5b4504 SHA512 554ad9c1b5426dcb9e1d89fff35d08c1048beabb882362b1d0b86eef76169c0fc72ccaa235717614abbacc739443dc4c8dd84119ee4cf186aa5b8f2f3cfe713b
+DIST debootstrap_1.0.112.tar.gz 75438 BLAKE2B adc84e3e97e4d592a714347e4a41ef190906e25635c179dca2bd4012e486e701a74f34ac299db7c1f08e6c78d92b8cee3b28dd151cf81c501ed412dbf9dc800c SHA512 67dcf401ffc3c0e4698d351dbb9a2b5acbee40bc810b0c7b46eb2410fbac7597662fde3ac03905e6914bde7418de6b5b93d17c98fa8a60a1aed1a3e322b35efe
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.112.ebuild b/dev-util/debootstrap/debootstrap-1.0.112.ebuild
new file mode 100644
index 000000000000..6ace46fd199f
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.112.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}