summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-05 13:57:10 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-05 14:00:10 -0500
commitabbe89c2241490f807758dd2ac0cc3cf8ee68ee3 (patch)
treea27856ffa2fa084595e22caf8d7e9b7a8272ac51 /dev-util
parentdev-python/pylibmc: add 1.6.2 (diff)
downloadgentoo-abbe89c2241490f807758dd2ac0cc3cf8ee68ee3.tar.gz
gentoo-abbe89c2241490f807758dd2ac0cc3cf8ee68ee3.tar.bz2
gentoo-abbe89c2241490f807758dd2ac0cc3cf8ee68ee3.zip
dev-util/github-cli: add 2.14.3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/github-cli/Manifest2
-rw-r--r--dev-util/github-cli/github-cli-2.14.3.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/github-cli/Manifest b/dev-util/github-cli/Manifest
index 7da0067c9091..bc0727811d30 100644
--- a/dev-util/github-cli/Manifest
+++ b/dev-util/github-cli/Manifest
@@ -2,3 +2,5 @@ DIST github-cli-2.11.3-deps.tar.xz 76137064 BLAKE2B 6b8a224f8e0b05c32c8be83b4f5a
DIST github-cli-2.11.3.tar.gz 716386 BLAKE2B dcb07cda11e03ffe75a9ec2fcb0ed33c1f2c6bb7599ed1b47ee9e1e0df609fa21ae2dd043be417cfee75dcb3686290f510c0fdffc0b1df08f816ab2ac79d940b SHA512 952cd7c2a327c7169e201a4aa7c26a0e5c09a1ecef51b8d7c620fa9a849c2e8cc61447333f785851487a68d058b869e10bb290188594bd2fb00b0384297bdfd8
DIST github-cli-2.12.1-deps.tar.xz 76485020 BLAKE2B c2d7e31a2fba9c34fc75c8d8f6836accbd2029b8f6be51c4ffda3d96ec06b9f331700573ac8478550676ed9385b8bc34ffa02a81d91aec3bde4bece0addae668 SHA512 1aa684d5aad6c5da45d4e0d8fe2c282a563890d7f48260668b393b0e93674b5c75862a84c421c8600c92d09ebfe655baaa42e3e7a4dc2f7a0792384ea555b2fc
DIST github-cli-2.12.1.tar.gz 717685 BLAKE2B b9782846185b8fd5295651cfdd082b987555edd0c3ae2ef7e0d69e100f331ea89e5ae9b8824af013f008677df2a0e8313b52cd7e0d95110884a62eb9e6e5c32e SHA512 508f02cfb12bec485a6123bf04056e879832a762d7563c73d1f006f4c382cad75cfb73ae74f66f9ed90b0cfd68956434f2100bab1dd7c93ec6d0d7b3a9d2c13f
+DIST github-cli-2.14.3-deps.tar.xz 77143036 BLAKE2B 7f06905270a7c9b17bbe8a83353c57da84cb365283fbb4bc488f2ce8873de79494adcf9d34aacd057d7610c3a68107f7fa19fcf74e885025a5e9f44ba49890a0 SHA512 da2b7d57160d22645b491fa8ffc93148c096a10b65aa9d4d4b8b4b1837460f3c5296d704e6f4fa0fd709d3f7c590cdf39c4c637c38b255c8b389ef106c35fb90
+DIST github-cli-2.14.3.tar.gz 716098 BLAKE2B 7b45f97859501be4e639584e287d2114b9ed87402d3f35cc56eebdef8bf2b3cf8b9ecff633cf44a822edf20a5000c38a5b1c38822b0bf670d6c4c9c4e5e1a052 SHA512 460f3c053c1f0bea458f7a891f2b1a4cbd68b754bc165e3b097215748fc220f96138cf010608092702c86403d4551b288faba4349a69ae0e92b93ef4564825b5
diff --git a/dev-util/github-cli/github-cli-2.14.3.ebuild b/dev-util/github-cli/github-cli-2.14.3.ebuild
new file mode 100644
index 000000000000..77fd1c37e6b9
--- /dev/null
+++ b/dev-util/github-cli/github-cli-2.14.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 flag-o-matic go-module
+
+DESCRIPTION="GitHub CLI"
+HOMEPAGE="https://github.com/cli/cli"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cli/cli.git"
+else
+ SRC_URI="https://github.com/cli/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+ S="${WORKDIR}/cli-${PV}"
+fi
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
+ # Filter '-flto*' flags to avoid build failures.
+ filter-flags "-flto*"
+ # Filter '-ggdb3' flag to avoid build failures. bugs.gentoo.org/847991
+ filter-flags "-ggdb3"
+ # Go LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ unset LDFLAGS
+ # Once we set up cross compiling, this line will need to be adjusted
+ # to compile for the target.
+ # Everything else in this function happens on the host.
+ emake
+
+ einfo "Building man pages"
+ emake manpages
+
+ einfo "Building completions"
+ go run ./cmd/gh completion -s bash > gh.bash-completion || die
+ go run ./cmd/gh completion -s zsh > gh.zsh-completion || die
+}
+
+src_install() {
+ dobin bin/gh
+ dodoc README.md
+
+ doman share/man/man?/gh*.?
+
+ newbashcomp gh.bash-completion gh
+ insinto /usr/share/zsh/site-functions
+ newins gh.zsh-completion _gh
+}