summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-23 19:51:34 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-17 16:55:30 +0100
commitb22e8ba8a608214053ec2434ec118d54ca32fc73 (patch)
treed9578f4874ecde8ebc74a30eaea2c65aa5ff8046 /dev-util
parentdev-db/postgresql: arm stable, bug #602130 (diff)
downloadgentoo-b22e8ba8a608214053ec2434ec118d54ca32fc73.tar.gz
gentoo-b22e8ba8a608214053ec2434ec118d54ca32fc73.tar.bz2
gentoo-b22e8ba8a608214053ec2434ec118d54ca32fc73.zip
dev-util/mdds: Drop eutils.eclass, more EAPI 6 polish
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mdds/mdds-1.2.2.ebuild4
-rw-r--r--dev-util/mdds/mdds-9999.ebuild7
2 files changed, 5 insertions, 6 deletions
diff --git a/dev-util/mdds/mdds-1.2.2.ebuild b/dev-util/mdds/mdds-1.2.2.ebuild
index bdb723486a58..4cac987a4f98 100644
--- a/dev-util/mdds/mdds-1.2.2.ebuild
+++ b/dev-util/mdds/mdds-1.2.2.ebuild
@@ -7,7 +7,7 @@ EAPI=6
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit eutils toolchain-funcs ${GITECLASS}
+inherit toolchain-funcs ${GITECLASS}
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
@@ -31,7 +31,7 @@ DEPEND="${RDEPEND}
DOCS=() # buildsystem installs docs
src_prepare(){
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index f2e2b99b38c2..867cc2658844 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=6
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit eutils toolchain-funcs ${GITECLASS}
+inherit toolchain-funcs ${GITECLASS}
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
@@ -31,15 +31,14 @@ DEPEND="${RDEPEND}
DOCS=() # buildsystem installs docs
src_prepare(){
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
$(use_enable doc docs) \
- $(use_enable valgrind memory_tests) \
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable valgrind memory_tests)
}
src_compile() { :; }