summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-07-25 11:54:51 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-07-25 11:55:03 +0300
commitb504f96fb78b39263a534ba88e83d666fe4bf01c (patch)
treeecabfcb36b655568ecf7e20ddaffdd408bd3135a /dev-util
parentapp-text/csvfix: inherit missing eutils eclass and fix tests (diff)
downloadgentoo-b504f96fb78b39263a534ba88e83d666fe4bf01c.tar.gz
gentoo-b504f96fb78b39263a534ba88e83d666fe4bf01c.tar.bz2
gentoo-b504f96fb78b39263a534ba88e83d666fe4bf01c.zip
dev-util/pycharm-community: Version bump (v2019.2)
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2019.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index ae7f8514d692..44fa551bd375 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,3 +1,4 @@
DIST pycharm-community-2019.1.1.tar.gz 332489780 BLAKE2B 2cc7dcbab5fa321e423991622b4e7c9e41c184312a4b3c3a8b900b1ea2436d9f6009e26ffca12f3335be8bb520941c6ac6b579f3e6f2fc0f1b148a9a00ab1868 SHA512 28d7a3353bec271f0a57bea3c44fc788a5b3a5215dff737ba293c2ce73509d06b217ee1615901c91e5895d61a58a2b696c50ae760b6b3a88b472f3746f28bcbf
DIST pycharm-community-2019.1.2.tar.gz 333983594 BLAKE2B f5dfa1986d88c7598cfbd5050c385a1b1b3374286e57fd513a94eb19bc42116b1ceef757d194ef1df66739b25f10663a74e374785b4c5584aec9b8900e67dd0c SHA512 48782960022efe48f37b2bdec0be1f15741f6dde2a2dcec686ecfb07c81996c3d6fc46cf3eda2fa4cc53a67f7ec47909e47ed57b2edbf973482ca37781067415
DIST pycharm-community-2019.1.3.tar.gz 334018235 BLAKE2B 8e4c400685e69aaa53426dee848d5f14a0c40b88232ee8cb8c0c0f2f727c68b9212600dab7717ec77c1cd4b42666bad965fcbc217e3158d357b5a5edd6a94e26 SHA512 42627af39a8530931442c8419ebee4d999faad40a203519fc8564e4b8b14d2476e8426e9976e487c92e4398db8efb15c5e2d28536b1c7b374898f9dc0021acbe
+DIST pycharm-community-2019.2.tar.gz 359295798 BLAKE2B 9a1b19e93d0d2cba6c7dd2c059d511e4d193b6bd9e5f1900c3aadd6ff322891c834947360715c8f41e5112f7a71d3b5b09ed7e23dcf3dd8c6c4de9c4eaf16b5b SHA512 490925de309bcb0ef052593e517f3d701ae1d82b05d4ea38bb7bb5eef86e9df21472e395fadbb21906fa1024358ae599285fba8fdb72b0ddb7f1e8f7f26ac046
diff --git a/dev-util/pycharm-community/pycharm-community-2019.2.ebuild b/dev-util/pycharm-community/pycharm-community-2019.2.ebuild
new file mode 100644
index 000000000000..3bd1b2cb4101
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2019.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}