summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-11 16:29:31 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-11 22:40:19 -0700
commitc1490fef73f2c45f31cda73cb30ed4640b7f7186 (patch)
tree657fb976e9a918e3a538e9108aaac42790c30e21 /dev-util
parentdev-python/ttystatus: Version bump to 0.36 (diff)
downloadgentoo-c1490fef73f2c45f31cda73cb30ed4640b7f7186.tar.gz
gentoo-c1490fef73f2c45f31cda73cb30ed4640b7f7186.tar.bz2
gentoo-c1490fef73f2c45f31cda73cb30ed4640b7f7186.zip
dev-util/cmdtest: Version bump to 0.32
A bunch of things too: - Port to EAPI=7 - Fix incorrect license - HTTPS homepage - Use tarball from cgit in SRC_URI Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmdtest/Manifest1
-rw-r--r--dev-util/cmdtest/cmdtest-0.32.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/cmdtest/Manifest b/dev-util/cmdtest/Manifest
index b3446cbf655e..0fa8cf8c07ef 100644
--- a/dev-util/cmdtest/Manifest
+++ b/dev-util/cmdtest/Manifest
@@ -1 +1,2 @@
+DIST cmdtest-0.32.tar.gz 48945 BLAKE2B 64c09a0f7dd66644d8ce785d633af2cc62ce0cba1a636cf18e650fdf0268987ad647509e17ed2c614b48164f9e9fbd6dcb64d6fa0a47ec6dcf24d82b69732857 SHA512 1d6d49f63067cd0343b0123eaa84326042a6382abccb624015ab5517809a11ad149f75fc48cdea87b608d4b8778903fe1a9e68b7942a45a6498bdf7e3dbe3216
DIST cmdtest_0.30.orig.tar.xz 38508 BLAKE2B 7a27ed4930decdfbc49e922af9724ddba2daabc5af51faa6cafea1ca10dbf5137aa74ad9780156ff13f16e4c22fe5dba43401e22c6c2a7cabbd39d4139f4f515 SHA512 cbdebe175f09a99218d8ce0f2d1e49019f70b7f3ba112e2650e5a58e36a6f1d1b641c9aed5212e12023e956f999ef9cdba27aea7af9211f35a41874147a402af
diff --git a/dev-util/cmdtest/cmdtest-0.32.ebuild b/dev-util/cmdtest/cmdtest-0.32.ebuild
new file mode 100644
index 000000000000..225429335076
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.32.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="https://liw.fi/cmdtest/"
+SRC_URI="http://git.liw.fi/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+
+DEPEND="
+ dev-python/cliapp[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/ttystatus[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v -p '*_tests.py' || die
+}