summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-06 18:04:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-06 18:04:52 +0000
commitc6c5af07666191c3d728ff494ca7e5a39db4101b (patch)
tree66e32b18fe6a4bb3093ada9176cda0b73b16a17d /dev-util
parentnet-p2p/retroshare: revbump to make sure we really link to miniupnpc (diff)
downloadgentoo-c6c5af07666191c3d728ff494ca7e5a39db4101b.tar.gz
gentoo-c6c5af07666191c3d728ff494ca7e5a39db4101b.tar.bz2
gentoo-c6c5af07666191c3d728ff494ca7e5a39db4101b.zip
dev-util/ccache: disable automagic ccache and ld detection
Reported-by: Thomas Deutschmann Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/ccache-4.2.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-4.2.ebuild b/dev-util/ccache/ccache-4.2.ebuild
index 6988793a4790..3f58044c6822 100644
--- a/dev-util/ccache/ccache-4.2.ebuild
+++ b/dev-util/ccache/ccache-4.2.ebuild
@@ -50,6 +50,16 @@ src_prepare() {
tc-export CC OBJDUMP
}
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DUSE_FASTER_LINKER=OFF
+ -DZSTD_FROM_INTERNET=OFF
+ )
+
+ cmake_src_configure
+}
+
src_install() {
cmake_src_install