summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-21 00:51:11 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-21 00:51:34 -0400
commitccf5020ee562d493f8b3ff77c498ecf9e8311f5d (patch)
treeedfa4fb368fe10b1430c622c59b35f673218441e /dev-util
parentdev-util/crash: version bump to 7.1.4 (diff)
downloadgentoo-ccf5020ee562d493f8b3ff77c498ecf9e8311f5d.tar.gz
gentoo-ccf5020ee562d493f8b3ff77c498ecf9e8311f5d.tar.bz2
gentoo-ccf5020ee562d493f8b3ff77c498ecf9e8311f5d.zip
dev-util/crash: fix build w/newer glibc #580244
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/crash/crash-7.1.4.ebuild1
-rw-r--r--dev-util/crash/files/crash-7.1.4-sysmacros.patch27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/crash/crash-7.1.4.ebuild b/dev-util/crash/crash-7.1.4.ebuild
index 91e7fb09561a..6583d7e9041b 100644
--- a/dev-util/crash/crash-7.1.4.ebuild
+++ b/dev-util/crash/crash-7.1.4.ebuild
@@ -16,4 +16,5 @@ IUSE=""
src_prepare() {
epatch "${FILESDIR}"/${PN}-5.1.1-install-fix.patch
+ epatch "${FILESDIR}"/${PN}-7.1.4-sysmacros.patch #580244
}
diff --git a/dev-util/crash/files/crash-7.1.4-sysmacros.patch b/dev-util/crash/files/crash-7.1.4-sysmacros.patch
new file mode 100644
index 000000000000..6e6d40cca4d2
--- /dev/null
+++ b/dev-util/crash/files/crash-7.1.4-sysmacros.patch
@@ -0,0 +1,27 @@
+From f22dabb45448e5a8d2df85703fd72b0f83fe7eda Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 21 Apr 2016 00:44:04 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev
+
+These funcs are defined in the sys/sysmacros.h header, not sys/types.h.
+Linux C libraries are updating to drop the implicit include, so we need
+to include it explicitly.
+---
+ filesys.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/filesys.c b/filesys.c
+index 2ed25f4..9b59998 100644
+--- a/filesys.c
++++ b/filesys.c
+@@ -16,6 +16,7 @@
+ */
+
+ #include "defs.h"
++#include <sys/sysmacros.h>
+ #include <linux/major.h>
+ #include <regex.h>
+ #include <sys/utsname.h>
+--
+2.7.4
+