summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-13 16:09:39 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-13 16:19:13 -0500
commitcdf5b5392ca1f171e9a422b8206984f3b348a282 (patch)
tree17f450763f0e63b52297bf7fe02e5bfb00c0b82e /dev-util
parentdev-util/rr: drop libpfm dep (diff)
downloadgentoo-cdf5b5392ca1f171e9a422b8206984f3b348a282.tar.gz
gentoo-cdf5b5392ca1f171e9a422b8206984f3b348a282.tar.bz2
gentoo-cdf5b5392ca1f171e9a422b8206984f3b348a282.zip
dev-util/rr: clean up build/test deps
We only need zlib & gdb at runtime. All the other deps in here are for building & testing only, so drop them from RDEPEND.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rr/rr-4.5.0.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/dev-util/rr/rr-4.5.0.ebuild b/dev-util/rr/rr-4.5.0.ebuild
index 6624a538149a..b83875db0e0a 100644
--- a/dev-util/rr/rr-4.5.0.ebuild
+++ b/dev-util/rr/rr-4.5.0.ebuild
@@ -16,15 +16,18 @@ SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.t
LICENSE="MIT BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/pexpect[${PYTHON_USEDEP}]
- sys-libs/zlib
- ${PYTHON_DEPS}"
-
-RDEPEND="
- sys-devel/gdb[xml]
- ${DEPEND}"
+IUSE="test"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}
+ sys-devel/gdb[xml]"
+# Add all the deps needed only at build/test time.
+DEPEND+="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-devel/gdb[xml]
+ )
+ ${PYTHON_DEPS}"
pkg_setup() {
if use kernel_linux; then
@@ -39,3 +42,11 @@ src_prepare() {
sed -i 's:-Werror::' CMakeLists.txt || die #609192
}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}