summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-22 21:00:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-22 23:00:50 +0100
commitce8381097ae89c5795e482a429fc4b8943c7e5f3 (patch)
tree6b5f8978a1057a5f87efd37c4daf27ec64f3062e /dev-util
parentdev-util/cppcheck: Sort DEPENDs (diff)
downloadgentoo-ce8381097ae89c5795e482a429fc4b8943c7e5f3.tar.gz
gentoo-ce8381097ae89c5795e482a429fc4b8943c7e5f3.tar.bz2
gentoo-ce8381097ae89c5795e482a429fc4b8943c7e5f3.zip
dev-util/cppcheck: Switch to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/cppcheck-1.81.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/cppcheck/cppcheck-1.81.ebuild b/dev-util/cppcheck/cppcheck-1.81.ebuild
index 765ecfadc61a..c1c281e82e29 100644
--- a/dev-util/cppcheck/cppcheck-1.81.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.81.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-inherit distutils-r1 eutils flag-o-matic qmake-utils toolchain-funcs
+inherit distutils-r1 flag-o-matic qmake-utils toolchain-funcs
DESCRIPTION="static analyzer of C/C++ code"
HOMEPAGE="http://cppcheck.sourceforge.net"
@@ -28,17 +28,17 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}"/${PN}-1.75-tinyxml2.patch )
+
src_prepare() {
+ default
append-cxxflags -std=c++0x
# Drop bundled libs, patch Makefile generator and re-run it
rm -r externals/tinyxml || die
- epatch "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
tc-export CXX
emake dmake
./dmake || die
-
- default
}
src_configure() {