summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2021-01-04 22:55:58 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2021-01-04 22:55:58 +0200
commitceb696f1e79ad43e5ab0c027d8391b50b602c57e (patch)
treed5f5c601321b661f0768d2c1d23ad884a4ae01f4 /dev-util
parentx11-misc/read-edid: Remove unnecessary -* (diff)
downloadgentoo-ceb696f1e79ad43e5ab0c027d8391b50b602c57e.tar.gz
gentoo-ceb696f1e79ad43e5ab0c027d8391b50b602c57e.tar.bz2
gentoo-ceb696f1e79ad43e5ab0c027d8391b50b602c57e.zip
Revert "dev-util/lttng-ust: Remove old" - Seems like sparc is stable again...
This reverts commit a9426af594c121fc32217227cddb3a58819192cf. Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lttng-ust/Manifest1
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.8.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/Manifest b/dev-util/lttng-ust/Manifest
index abe29fcc2034..c19ca7642412 100644
--- a/dev-util/lttng-ust/Manifest
+++ b/dev-util/lttng-ust/Manifest
@@ -1,2 +1,3 @@
DIST lttng-ust-2.11.0.tar.bz2 824285 BLAKE2B 161d50282a95cce47ab3811216241ade73e2002d8f03aa2266b5add36d06552f5620b912eeecff1173f43eec107b385f1b93783905f36a42baf5a63c37ea35fc SHA512 fb7258961a7e913487806a7e0129c95becff8c631382b119ff1d78f95cdd7460ec24e62671642160fdb006a3a292b2b10f35c8424f0367ce7c6a41cbcca77a09
DIST lttng-ust-2.12.0.tar.bz2 853127 BLAKE2B 6a6655a4aa33ec6318255d05d0e000c19fb66d4049873f091b8e19f3f9ea0c15731db70af77dbab1d597edcafcd745f1dae2670cd38759c9b54ea38b1135b590 SHA512 d69772170f57b9669b99cea372ca537777151a31b82002e1e5ec80da3ceb302c23f0f85d63a2c95c90a375b879e266aa5297e7d6444050dd40feb1253d863801
+DIST lttng-ust-2.8.1.tar.bz2 743271 BLAKE2B d6adac00525ab747306288dd71f27ce982dd93e4ff42b9938064ae1435ad1c0867acebe3030a33748dc9aa78b6200ba2c47631e4359a963772fc4685472d21ae SHA512 15c459620cb73ef5be8c7df2ef02663ef650555b973a3d1ed976ae38068b53a8c83143a611bcb53e91a3f211361c44cd2a331cb41dd53d28a69924f7ac44cc95
diff --git a/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild b/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
new file mode 100644
index 000000000000..a09a68a5beaf
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools versionator
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}