summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:08:07 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:19:29 -0400
commitd0ccd5a042c88cf8bc15801bd5e281781ca0686e (patch)
tree29ac62e6be038a19f839ae9596a957bbac4b67b5 /dev-util
parentdev-util/buildbot-pkg: Version bump to 3.1.1 (diff)
downloadgentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.tar.gz
gentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.tar.bz2
gentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.zip
dev-util/buildbot-www: Version bump to 3.1.1
sync KEYWORDS among the pkgs. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.1.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index 2ab314adb9e0..229a0b7860b7 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -4,3 +4,4 @@ DIST buildbot-www-2.8.2.tar.gz 3172352 BLAKE2B 8ead9e9eb046bf773bd70d312ae612dce
DIST buildbot-www-2.8.4.tar.gz 3170166 BLAKE2B d3d5c8a6b4b963cffaa75035e2f4a076af27c9f816a8e80b346bdeade55f01c7c8403612b8e6d12036261dabe6ab4f05ddb7ffce4e7369565d361fe7b062f691 SHA512 8b698b8b99b3f9b51df0ce230c3d6e5dea8d1c1278cb7372edd170844ec46f7fe213be20db628da244cd38daaa53b1e2fcbffd3ab3980eee35ccc6a9824c7ae5
DIST buildbot-www-3.0.2.tar.gz 3180864 BLAKE2B 772f23daf19ea964e4e65bb890e25bd90623e1eef8cb2845352e4e65884668d913aec98e292fb28121f1d87571430224eb5c70aca326f4c106d7125fbdc10570 SHA512 9be7271dbae3b62ee6fcb10441faaa9cab952b9db989275a62b7ca9d4c5dc342ec1decf33c267c0d2d8e095ab32f4493055cda1880f73818d26a98fab674a108
DIST buildbot-www-3.1.0.tar.gz 3180991 BLAKE2B d2ebe82e97cb92c97c43059555c276602dc128164bed2ecf7014ad81b7b2375568dcbc3d35be2e98c737be8e7c2774d77f0361625d96db3da311fc5da7aa5ee8 SHA512 db1be3054bc3b6112f1f4ebe846f02a1da096ffbf29bfe1b99d254a759a67d64849e3c1e3df7edbada200e791d62904a2e2c66e7e0f8273feb3dedd463efc69a
+DIST buildbot-www-3.1.1.tar.gz 3180995 BLAKE2B 16c6e0966d64cc6631df8b4980bb20617707ebd3fca279cc6aa614e83bf0c3537e992f120670c00992dce854304ddf421143e96565e05482bd3d231f15fbe2c6 SHA512 89a1f88958fc509e33d6d5f2e8f0690ff87069eff60296926b3cf7021a060fc3918a990e54e5750922d6152b9d1e9257a973df16630332be9fd10a3643520354
diff --git a/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild b/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild
new file mode 100644
index 000000000000..34eaab6d6621
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"