summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-22 16:59:39 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 18:04:02 +0200
commite25f6fa23f1f30b6b05489f07328a8cd5d7a2c68 (patch)
tree291f029b8e7c78a685badcd5bf00bf4f0942e5bb /dev-util
parentx11-misc/lightdm-gtk-greeter: Add missing DEPEND on intltool (diff)
downloadgentoo-e25f6fa23f1f30b6b05489f07328a8cd5d7a2c68.tar.gz
gentoo-e25f6fa23f1f30b6b05489f07328a8cd5d7a2c68.tar.bz2
gentoo-e25f6fa23f1f30b6b05489f07328a8cd5d7a2c68.zip
dev-util/codeblocks: Fix segfault with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=625696 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5175
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/codeblocks/codeblocks-16.01.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/codeblocks/codeblocks-16.01.ebuild b/dev-util/codeblocks/codeblocks-16.01.ebuild
index 9f14a95f0a1b..047fa0975850 100644
--- a/dev-util/codeblocks/codeblocks-16.01.ebuild
+++ b/dev-util/codeblocks/codeblocks-16.01.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
+
WX_GTK_VER="2.8"
-inherit eutils wxwidgets
+inherit eutils flag-o-matic wxwidgets
DESCRIPTION="The open source, cross platform, free C++ IDE"
HOMEPAGE="http://www.codeblocks.org/"
@@ -29,8 +30,10 @@ DEPEND="${RDEPEND}
src_configure() {
touch "${S}"/revision.m4 -r "${S}"/acinclude.m4
-
setup-wxwidgets
+
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
econf \
--with-wx-config="${WX_CONFIG}" \
$(use_enable debug) \