summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-06-12 14:00:58 -0400
committerMike Gilbert <floppym@gentoo.org>2021-06-12 14:21:19 -0400
commite2b72a1641a2b5ab4a8902b77c273ec7cb2f3ca0 (patch)
tree93322301206b77887588b52eaf83fe11a84496ed /dev-util
parentsys-block/blktrace: bump using snapshot (diff)
downloadgentoo-e2b72a1641a2b5ab4a8902b77c273ec7cb2f3ca0.tar.gz
gentoo-e2b72a1641a2b5ab4a8902b77c273ec7cb2f3ca0.tar.bz2
gentoo-e2b72a1641a2b5ab4a8902b77c273ec7cb2f3ca0.zip
dev-util/meson: drop 0.56.2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.56.2.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 4e78be3c7562..765d085eb49a 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,2 +1 @@
-DIST meson-0.56.2.tar.gz 1794847 BLAKE2B 350427e2ff4b4fe688220ca6279ff3361e1b2c7c573e1e0185ea9014fda73bc68929256073fe05855e3403638257e26477868d0a5683a5b91f6a74ee55a01f0e SHA512 3b6cc5cae31d756b251ecde3483d3710bceff50cfd03ef6cf6f939d9e599998e61fcb03a2ee09d6a6f9bfa2198f43e7f20447359de3bff1055febcf03e82e514
DIST meson-0.57.2.tar.gz 1853721 BLAKE2B 9c167a21745719589a165e7ffc31007bd6307b347027f390fd660b2f44b5a2e6d8f36e999e15fa4b28ae269ddb0bb3897e0297288c59b62cc493aad058126293 SHA512 a3b0bf3d5e1d1b7ac7c97313f43046c94aa2a6b21964958569c89764dfda08db166adb89d48cbfad735bd472114587a71089d5e8b4f0fce04c3289da21b3f40e
diff --git a/dev-util/meson/meson-0.56.2.ebuild b/dev-util/meson/meson-0.56.2.ebuild
deleted file mode 100644
index 20afc602e2bf..000000000000
--- a/dev-util/meson/meson-0.56.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 2016-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" run_unittests.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- ${EPYTHON} -u run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-}