summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-06 15:59:29 -0500
committerTim Harder <radhermit@gentoo.org>2016-03-06 16:00:10 -0500
commitef1e3691a08f60f32162c99edac0678482e261d4 (patch)
tree9fa1b1d31873794debe05957c67cfa3be33ec61a /dev-util
parentx11-wm/muffin: x86 stable wrt bug #566378 (diff)
downloadgentoo-ef1e3691a08f60f32162c99edac0678482e261d4.tar.gz
gentoo-ef1e3691a08f60f32162c99edac0678482e261d4.tar.bz2
gentoo-ef1e3691a08f60f32162c99edac0678482e261d4.zip
dev-util/trinity: version bump to 1.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/trinity/Manifest1
-rw-r--r--dev-util/trinity/files/trinity-1.6-cflags.patch11
-rw-r--r--dev-util/trinity/trinity-1.6.ebuild45
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/trinity/Manifest b/dev-util/trinity/Manifest
index 6829e0b89208..579ef6af0714 100644
--- a/dev-util/trinity/Manifest
+++ b/dev-util/trinity/Manifest
@@ -1 +1,2 @@
DIST trinity-1.5.tar.xz 171684 SHA256 e7b641d21954873bac7b5c27e7a9986837e83ec14fa20c55901c4333cce22655 SHA512 58884c8e226258de6037e06029b6c593a99b467e9b107562458557954fd4af185f88fbcacc04fc52f05318a860ebab4605c227e6a02b32253439807d4071cd8d WHIRLPOOL e737ac877b95a62e40a2cc9273f0b0d4dc79275b6dafab85b54815f1581c9c824189d88781cc26468c56166f6e87273fc5df1b786b69069b1dc4654d2a874f43
+DIST trinity-1.6.tar.xz 177808 SHA256 e40efa320ddc814943e90be0386b5052ce0bbbc457b3f308fa973669d393a6d9 SHA512 43ceb5ef96e97d3c338deb582b250202073d6f203ee596ce676d77a52bcfe06f53e068d07a0ee9f1d49f74319e24ba885cb7529d8868ac67f0237f2c4cfde2de WHIRLPOOL f7afe7514fe2ac2b6de3c4a05f8a4bb0bb7a328267c093e924e6345f03ffa864be06a3223b32c24ab4e334b016868f66696417d7de30d2561ea71a1a67f45183
diff --git a/dev-util/trinity/files/trinity-1.6-cflags.patch b/dev-util/trinity/files/trinity-1.6-cflags.patch
new file mode 100644
index 000000000000..9243619decdf
--- /dev/null
+++ b/dev-util/trinity/files/trinity-1.6-cflags.patch
@@ -0,0 +1,11 @@
+--- trinity-1.6/Makefile
++++ trinity-1.6/Makefile
+@@ -10,7 +10,7 @@
+ CC := $(CROSS_COMPILE)$(CC)
+ LD := $(CROSS_COMPILE)$(LD)
+
+-CFLAGS += -Wall -W -g -O2 -I. -Iinclude/ -Wimplicit -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D__linux__
++CFLAGS += -Wall -W -I. -Iinclude/ -Wimplicit -D_GNU_SOURCE -D__linux__
+
+ # Only enabled during development, and on gcc 4.9+
+ CPP_MAJOR := $(shell $(CPP) -dumpversion 2>&1 | cut -d'.' -f1)
diff --git a/dev-util/trinity/trinity-1.6.ebuild b/dev-util/trinity/trinity-1.6.ebuild
new file mode 100644
index 000000000000..86d54f41a649
--- /dev/null
+++ b/dev-util/trinity/trinity-1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A Linux system call fuzz tester"
+HOMEPAGE="http://codemonkey.org.uk/projects/trinity/"
+SRC_URI="http://codemonkey.org.uk/projects/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ app-arch/xz-utils
+ sys-kernel/linux-headers
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ tc-export CC
+}
+
+src_configure() {
+ ./configure.sh || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Documentation/* README
+
+ if use examples ; then
+ exeinto /usr/share/doc/${PF}/scripts
+ doexe scripts/*
+ docompress -x /usr/share/doc/${PF}/scripts
+ fi
+}