summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-10 15:58:19 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-10 15:58:36 -0700
commitf21f6bf63437897c5142136a2e15276cd8fc7a4e (patch)
tree1c2b2774c77fcadd65f0d09c66fd9c2a214e33fa /dev-util
parentgames-board/sjeng: Respect CC by running eautoreconf (diff)
downloadgentoo-f21f6bf63437897c5142136a2e15276cd8fc7a4e.tar.gz
gentoo-f21f6bf63437897c5142136a2e15276cd8fc7a4e.tar.bz2
gentoo-f21f6bf63437897c5142136a2e15276cd8fc7a4e.zip
dev-util/bear: bump to 2.4.4
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bear/Manifest1
-rw-r--r--dev-util/bear/bear-2.4.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index bbfa7c76de56..414b55e796de 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1 +1,2 @@
DIST bear-2.4.3.tar.gz 49933 BLAKE2B 2a91c30d81f9d0e58a25458579f6b0c867c07d2e532bd2ed29305645e152bd564156f708c4a07a683577412b3fdab1f106685ecf1ad88eaad2f33f0bc43a5baa SHA512 a4690cfc9938d8752ca5c8322ca4c5039746ade059e4459e7f3f91b2bf3d36ea691a5d855cab7a4e7ad8ff76478c48c4394593e069a1cf8396ead41017421753
+DIST bear-2.4.4.tar.gz 50347 BLAKE2B 73fa332cf97413e55c588f8830806a26c6905299af902c6cf1f39fd576c6261690239c1b502b28b5a2aa24e5ca521c3f1dd58aacd60e00ece4fe1840f5656155 SHA512 4ee3fd5c846149029fe9e4104e2a0d0e318a15215aa80fc5dc376e22ebea510384b02d4d62765495343cab537bacd2b1b0130c00246e081feb4e543761a594e5
diff --git a/dev-util/bear/bear-2.4.4.ebuild b/dev-util/bear/bear-2.4.4.ebuild
new file mode 100644
index 000000000000..468a104719bb
--- /dev/null
+++ b/dev-util/bear/bear-2.4.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Build EAR generates a compilation database for clang tooling"
+HOMEPAGE="https://github.com/rizsotto/Bear"
+SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="test? (
+ app-shells/bash
+ $(python_gen_cond_dep '
+ dev-python/lit[${PYTHON_USEDEP}]
+ ')
+)"
+
+RDEPEND="${PYTHON_DEPS}"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P^}"
+
+src_compile() {
+ cmake_src_compile
+ # need to fix it now, before tests are run
+ python_fix_shebang "${BUILD_DIR}"/bear/bear
+ python_fix_shebang test/functional/tools/cdb_diff.py
+}
+
+src_test() {
+ if has sandbox ${FEATURES}; then
+ ewarn "\'FEATURES=sandbox\' detected"
+ ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
+ ewarn "Skipping tests"
+ elif
+ has usersandbox ${FEATURES}; then
+ ewarn "\'FEATURES=usersandbox\' detected"
+ ewarn "Skipping tests"
+ elif
+ has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
+ ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
+ ewarn "and will fail without generic cc symlink"
+ ewarn "Skipping tests"
+ else
+ einfo "removing unwanted/unsupported/xfail tests"
+ rm -v test/functional/cases/{end-to-end/scons.ft,intercept/cuda/successful_build.fts,run_pep8.ft} || die
+ einfo "test may use optional tools if found: qmake gfortran"
+ cmake_build check
+ fi
+}