summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-11-16 16:58:01 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-11-17 17:26:47 +0000
commitf2d04e503936b82e1e69e6aac21ea5a2344303c6 (patch)
tree02f3fcb75d3cd52d86d2a671395477c9041078a7 /dev-util
parentmedia-sound/qmmp: Removed old. (diff)
downloadgentoo-f2d04e503936b82e1e69e6aac21ea5a2344303c6.tar.gz
gentoo-f2d04e503936b82e1e69e6aac21ea5a2344303c6.tar.bz2
gentoo-f2d04e503936b82e1e69e6aac21ea5a2344303c6.zip
dev-util/bazel: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.4.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index 387eb8fd625c..ef34529106f0 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1 +1,2 @@
DIST bazel-0.3.2.tar.gz 145095554 SHA256 9692ac3318a40e8a0530f68bbfc473ae5f6a4a5c0fe08d2f88612ca4d40ba54a SHA512 975faf5830e952bea5d3fa8d127e0d5d9654af83f1fba0d7e26f9e1c2c71dd58542efea2382b0c52c9fd24ae43ec66a3ca7451309f02fd65c0896bbbdb3c79f5 WHIRLPOOL ab487f84e8126ab2badfd84d1fe757170900fbb2f88dff79d6867fb694bbb8adf226b7b89bfdb9cf207595bfd235583a54b8102a1a009f58be7bd3be039e1aaa
+DIST bazel-0.4.0.tar.gz 159192903 SHA256 2370649043b5b3c407016a74946d5c443dd5c8ba43c1ffe28b83553983e5057c SHA512 be5c91b8c8e7061c4992d477d9ffa7eaf11fcc064a54ae2db7ccf8fa931223e758288876b8c191f3d4ddf16dd1858b2c99ce1ef58da71dc2edbcc57b2036f871 WHIRLPOOL 72d720b57241bf5a4769d3e84d6dee787aed9b4bb32353a32f2a3580cd74b6185db2c002c1e403246c511af7072ce24ba3cb71a12fa426f97faf4dbae9dff9d1
diff --git a/dev-util/bazel/bazel-0.4.0.ebuild b/dev-util/bazel/bazel-0.4.0.ebuild
new file mode 100644
index 000000000000..a78ef97d2ae8
--- /dev/null
+++ b/dev-util/bazel/bazel-0.4.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+DEPEND="virtual/jdk:1.8"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build //scripts:bazel-complete.bash || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ dobin output/bazel
+ newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ doins -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ doins -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}