summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-25 22:17:06 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-25 22:17:29 +0200
commitfa836360d767cb4ecee7f2635827ebdacbcede65 (patch)
treedeeb101116c3eff9ddbd9bb72b5e92a2a42092d5 /dev-util
parentapp-admin/mcollective: 2.11.3 bup (diff)
downloadgentoo-fa836360d767cb4ecee7f2635827ebdacbcede65.tar.gz
gentoo-fa836360d767cb4ecee7f2635827ebdacbcede65.tar.bz2
gentoo-fa836360d767cb4ecee7f2635827ebdacbcede65.zip
dev-util/scala-ide: revert 2fe1fffbf58ed7804a381000427a1424dbc91385.
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scala-ide/Manifest1
-rw-r--r--dev-util/scala-ide/scala-ide-4.3.0.ebuild17
-rw-r--r--dev-util/scala-ide/scala-ide-4.6.1.ebuild38
3 files changed, 8 insertions, 48 deletions
diff --git a/dev-util/scala-ide/Manifest b/dev-util/scala-ide/Manifest
index 5a44a8713364..1ee3b3c78746 100644
--- a/dev-util/scala-ide/Manifest
+++ b/dev-util/scala-ide/Manifest
@@ -2,4 +2,3 @@ DIST scala-SDK-4.1.0-vfinal-2.11-linux.gtk.x86.tar.gz 232347349 SHA256 1d7054b49
DIST scala-SDK-4.1.0-vfinal-2.11-linux.gtk.x86_64.tar.gz 232491001 SHA256 d3e9efe1176d979dc0fe2a9457f70068b5a3fd23635a07bcd5639e2345897aca SHA512 d5b8fe3cb3d6623e2f29e0ad5d279b363143c9b392ea5d91092ecb9de765828ac0c50c74ff879f7c825099b22a833ad3acbb0c2cfcd51c769ee19082905b63eb WHIRLPOOL 8007d41e9695c6ae5c3094906ebc6fba263d8d005f6763ce70eb4398db266ea1aff64bc4bc24bc216d0e869e839a92298bb3f85f8149608dd2986d36a3863def
DIST scala-SDK-4.3.0-vfinal-2.11-linux.gtk.x86.tar.gz 237898838 SHA256 3f46b5576e72f8555b322bf8a1ff8357372c5ec159f9171f2d81f78c5d753f78 SHA512 b8fcac4e0eeace0d146028e2f1551cdd3f58d38830430080e7aa5ccd581ae6a31992a5d1f39b6e8fcb30979953f0b9777166d2de73d7310621c9e7fa2e620f3d WHIRLPOOL 05756a8be2e23d50a84ea36a786f5b442c18da94e40b14c199c034880b226e0fdd8a06f4c2fbfa7238c5ab4343ea68bf71ea91830f05cd7226aba40d5389c05c
DIST scala-SDK-4.3.0-vfinal-2.11-linux.gtk.x86_64.tar.gz 238040666 SHA256 bc6b9289ab318a4eb7e273a2990351cc051a00051b208192591c0a6fad5da20d SHA512 70f3a481065f79532a4a0463e2549e4ecb0590e6d6e1ca7704629eced4393a7e4f7b22cd7c368a852c1d8f63cff949db02a7dd7f1be71cd30f52219c5cfbefd5 WHIRLPOOL 11dddf53d364864198629dfefdc84202fc19876d325e7738488402b7614faa5d6b88e8f2867810c854e9110fd3596043529a2e6f588107af519ae807a9d711d8
-DIST scala-SDK-4.6.1-vfinal-2.12-linux.gtk.x86_64.tar.gz 265183376 SHA256 6d15718fff347597ffc3147eb1f01f9acd73bba8226ff91cbdb697fb69055c45 SHA512 4102e62aafb976c0e5e11f1cdde187d0d584990ed4eba912317e9afd801d22d44e7c9ea96895c992f9a6c93570fc560403b767e6bc514c7f0220e8c8ebb6705e WHIRLPOOL 96af6e29a0ccaa1cba1da36e05f4eaa67dfb964410f8e2b228d8cf153ddf8269e8d081b8f7acf29a24c5ddb82262b9e3ff3e2e4fa8f74ab482635a4cfba329c9
diff --git a/dev-util/scala-ide/scala-ide-4.3.0.ebuild b/dev-util/scala-ide/scala-ide-4.3.0.ebuild
index 4fe500b2db61..8e637c5ccdea 100644
--- a/dev-util/scala-ide/scala-ide-4.3.0.ebuild
+++ b/dev-util/scala-ide/scala-ide-4.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,28 +28,27 @@ RDEPEND=">=virtual/jdk-1.6
|| (
dev-lang/scala
dev-lang/scala-bin
- )
-"
+ )"
MY_D="/opt"
src_unpack() {
default
unpack ${A}
- mv "${WORKDIR}"/eclipse "${WORKDIR}"/"${P}"
+ mv "${WORKDIR}"/eclipse "${WORKDIR}"/"${P}" || die
}
src_prepare() {
- mv "${WORKDIR}"/"${P}"/eclipse "${WORKDIR}"/"${P}"/"${PN}"
+ mv "${WORKDIR}"/"${P}"/eclipse "${WORKDIR}"/"${P}"/"${PN}" || die
}
src_install() {
cd "${D}" || die
- dodir "${MY_D}" || die
+ dodir "${MY_D}"
insinto "${MY_D}"
- doins -r "${WORKDIR}"/"${P}" || die
+ doins -r "${WORKDIR}"/"${P}"
insopts -m 0755
insinto "${MY_D}"/"${P}"
- doins "${WORKDIR}"/"${P}"/"${PN}" || die
- dosym ${MY_D}/${P}/${PN} /usr/bin/${PN} || die
+ doins "${WORKDIR}"/"${P}"/"${PN}"
+ dosym ${MY_D}/${P}/${PN} /usr/bin/${PN}
}
diff --git a/dev-util/scala-ide/scala-ide-4.6.1.ebuild b/dev-util/scala-ide/scala-ide-4.6.1.ebuild
deleted file mode 100644
index 4585a286bdb6..000000000000
--- a/dev-util/scala-ide/scala-ide-4.6.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-pkg-opt-2
-
-E_V="-neon-212-20170609"
-S_V="2.12'"
-
-S_PACK="${PN/-/}-pack"
-S_SDK="${PN%-*}-SDK-${PV}-vfinal"
-
-DESCRIPTION="The Scala IDE"
-HOMEPAGE="http://www.scala-ide.org"
-KEYWORDS="~amd64"
-SRC_URI="
- https://downloads.typesafe.com/${S_PACK}/${PV}-vfinal${E_V}/${S_SDK}-${S_V}-linux.gtk.x86_64.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-
-RDEPEND="
- >=virtual/jdk-1.8
- >=dev-lang/scala-${S_V}"
-
-MY_D="/opt"
-S="${WORKDIR}/eclipse"
-
-src_install() {
- mv eclipse "${PN}" || die
-
- dodir "${MY_D}"
- mv "${S}" "${D}/${MY_D}/${P}" || die
-
- insinto "${MY_D}/${P}"
- dosym "${MY_D}/${P}/${PN}" "/usr/bin/${PN}"
-}