summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-29 11:46:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-29 11:46:14 +0300
commitfb4a26b775ece1646df95b3f57026701806ab910 (patch)
tree3c0c18db8ab02eef8a73ba013439f91da4d7fe42 /dev-util
parentdev-java/openjdk-jre-bin: remove postinst warnings from :8 (diff)
downloadgentoo-fb4a26b775ece1646df95b3f57026701806ab910.tar.gz
gentoo-fb4a26b775ece1646df95b3f57026701806ab910.tar.bz2
gentoo-fb4a26b775ece1646df95b3f57026701806ab910.zip
dev-util/pycharm-community: Version bump (v2019.3.1)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 90c08e4afa63..a55a26d26855 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,4 +1,5 @@
DIST pycharm-community-2019.2.3.tar.gz 360509772 BLAKE2B 8924e6b5e2823c26a96531d14bc60f01f0849a5cca3c87bdff7c23c304081e668aecb1b2c681622c472cacf4b2e1f58c5fa4e42624f204491d27e37785146fd3 SHA512 65f834ba20cddb93533d596430f8b537167f32e99d224758d9fd4407f95304609912dec7f11cf61f9edf2e30722f1624250f44765c0f83dcbf6815bb8c35d9d9
DIST pycharm-community-2019.2.4.tar.gz 363680469 BLAKE2B d550dc8144746c0b4bcff408531eba289896dc325eea99a2d2a4363cfaca00de55045cff54a3163acd15105b0705dc48ac28374831bd6f0f6842823cdf4b5ceb SHA512 f7d12ccd8309bf547d1f37853977772d7ab023ebebcc71c6f09f71a21ae9bfceb8718d9ebf77a7717e1b145f56ea902d8d02d573d658b7db540696fb9630b0d3
DIST pycharm-community-2019.2.5.tar.gz 363809835 BLAKE2B 12310ca0c5a497d70f644d7eaf0b2de2ebe3c6bbaa30727df3fb7381e063facf3ee256af0a8636317559dab2573092e482dfa5baccfc9bef20cafd12e9c28734 SHA512 9054c6a9e48e609b45d786b66db045457d33f916248e949a8d6997e53e4a3b5fe0da00757f13c3cb48ab5f074c971e200d42b14f7941a7d91e1c903f3b5e244a
+DIST pycharm-community-2019.3.1.tar.gz 389620376 BLAKE2B a780ab27feef9747539d9cd607b67c7e047d0a7c1eb6b090a63c4f1c11c80c49e5091a29d80ea249ace1f16acdcd418f0a4901e10c2c623e792da9d7d0e7c9d6 SHA512 4bfa78a5f3993e85ad5ba624ed9e586d195b9f4bffa8bd764e8dba27edc1cdc0bd2b3bba86135156c1f306601db290703e61e7561badc7dcb634dc5826134b1f
DIST pycharm-community-2019.3.tar.gz 385414079 BLAKE2B 6a3a4393ba6ef84a7ec09c2f6ea0ce631ea1d4a004686beeedbee91ee2d3de6273455ef1e8e9f8f0f42360f9b4e42741d81a11825fd9c53e2ed90a987661ba20 SHA512 371619a5716de4df1fd68307f87c877eb435b30f797f06305b228566380f658a18f25022deaa581af9653a5745f2cee0157a9ae83b7be9b97f80aea8b4889496
diff --git a/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild b/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild
new file mode 100644
index 000000000000..3bd1b2cb4101
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}