summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/colorsvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/colorsvn')
-rw-r--r--dev-vcs/colorsvn/Manifest1
-rw-r--r--dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild54
-rw-r--r--dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch43
-rw-r--r--dev-vcs/colorsvn/metadata.xml12
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-vcs/colorsvn/Manifest b/dev-vcs/colorsvn/Manifest
new file mode 100644
index 000000000000..15c497f37ef7
--- /dev/null
+++ b/dev-vcs/colorsvn/Manifest
@@ -0,0 +1 @@
+DIST colorsvn-0.3.2.tar.gz 98460 SHA256 ee3bff9b897b268a8a62cee8f6162b562127a4c2becba3f20152f6cde83cdbe4 SHA512 1918d3609a871d8fa9e43cab5d32c5314505204deb9e7e0e8321c69c2f345b577a4572574fd7da7e428b8fca9228b2a48a81c8f1dc27c0aceca7e2596e13804f WHIRLPOOL 1b88225f871eca25a5cf82fcd6ad6a518fdf02cccebbb875d44df868033c721e17bade916014d0a71a4948e86430306db811edbb62e24f9b6b28e60577bedc9a
diff --git a/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild b/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..a3506f4e0292
--- /dev/null
+++ b/dev-vcs/colorsvn/colorsvn-0.3.2-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Subversion output colorizer"
+HOMEPAGE="http://colorsvn.tigris.org"
+SRC_URI="http://www.console-colors.de/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-vcs/subversion"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # rxvt-unicode isn't listed by default :)
+ sed -i -e 's:rxvt:rxvt rxvt-unicode:' colorsvnrc-original || die
+ # Fix confdir location for Prefix, #435434
+ sed -i \
+ -e '/^confdir/d' \
+ -e 's/$(confdir)/$(sysconfdir)/g' \
+ Makefile.in || die
+
+ epatch "${FILESDIR}/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch"
+}
+
+src_compile() {
+ # bug 335134
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CREDITS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The default settings are stored in /etc/colorsvnrc."
+ einfo "They can be locally overridden by ~/.colorsvnrc."
+ einfo "An alias to colorsvn was installed for the svn command."
+ einfo "In order to immediately activate it do:"
+ einfo "\tsource /etc/profile"
+ einfo "NOTE: If you don't see colors,"
+ einfo "append the output of 'echo \$TERM' to 'colortty' in your colorsvnrc."
+ einfo
+}
diff --git a/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch b/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch
new file mode 100644
index 000000000000..6fb1e4b0313b
--- /dev/null
+++ b/dev-vcs/colorsvn/files/0001-Don-t-colorize-svn-mkdir-bug-321451.-Use-IPC-open2-i.patch
@@ -0,0 +1,43 @@
+From 869595b958e80f8c05b823c0df514d3decbe6686 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Thu, 16 Sep 2010 13:04:25 +0200
+Subject: [PATCH] Don't colorize 'svn mkdir', bug 321451. Use IPC::open2 instead of open3 to avoid using STDERR, bug 326279.
+
+---
+ colorsvn-original | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/colorsvn-original b/colorsvn-original
+index 01d7be3..46f105b 100644
+--- a/colorsvn-original
++++ b/colorsvn-original
+@@ -56,7 +56,7 @@
+ # Foundation, Inc., 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA.
+
+ use Term::ANSIColor;
+-use IPC::Open3;
++use IPC::Open2;
+
+ use strict;
+ use warnings;
+@@ -115,7 +115,7 @@ our %commandmap = ( "add" => ["add"],
+ );
+
+ # never colorize this commands
+-our @preventcolor = ("commit", "help", "import", "lock", "switch", "propedit", "resolved", "revert", "unlock");
++our @preventcolor = ("commit", "help", "import", "lock", "switch", "propedit", "resolved", "revert", "unlock", "mkdir");
+
+ #
+ # set default values
+@@ -331,7 +331,7 @@ if (! -t STDOUT || $commit == 1 || !$colortty{$terminal} || !$commresolved )
+
+ # Keep the pid of the svn process so we can get its return
+ # code and use that as our return code.
+-my $svn_pid = open3('<&STDIN', \*SVNOUT, \*SVNOUT, $svnPath, @ARGV);
++my $svn_pid = open2(\*SVNOUT, '<&STDIN', $svnPath, @ARGV);
+ my $svnName = $svnPath;
+ $svnName =~ s,.*/(.*)$,$1,;
+
+--
+1.7.2.2
+
diff --git a/dev-vcs/colorsvn/metadata.xml b/dev-vcs/colorsvn/metadata.xml
new file mode 100644
index 000000000000..bb5e42d12c69
--- /dev/null
+++ b/dev-vcs/colorsvn/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <longdescription lang="en">
+ colorsvn is the Subversion output colorizer. Colorsvn was extracted from
+ kde-sdk and was extended with build process and configuration.
+ </longdescription>
+</pkgmetadata>