summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-15 15:24:01 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-15 15:24:18 +0100
commite2be79c8653df0816f7fe3d1986acee0eaf48a16 (patch)
tree08e105586e56c36c0423ac195d7a39af4a8cc469 /dev-vcs/cvs-fast-export
parentsys-kernel/linux-firmware: Add myself as co-maintainer (diff)
downloadgentoo-e2be79c8653df0816f7fe3d1986acee0eaf48a16.tar.gz
gentoo-e2be79c8653df0816f7fe3d1986acee0eaf48a16.tar.bz2
gentoo-e2be79c8653df0816f7fe3d1986acee0eaf48a16.zip
dev-vcs/cvs-fast-export: Version bump to 1.59
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 79611242d1be..fe684f927845 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1 +1,2 @@
DIST cvs-fast-export-1.57.tar.gz 503473 BLAKE2B 06d5b03d550be9604a04b4f03cd19d06abbe84efb6fbb424a3ae8c58f2964dff31e1718baf61adf70fe17c2beb6753cdd0fba9e0e1a5ba5e9d8ae7b87721a336 SHA512 bb129d58a66ca8aa9feb6dcdf6d83553ed1099d6023041c4fb8fa9b923461b6eb9e59ec304b3443f754d7710a2655fd2c104cbaa5ac604ee471de727b92fc091
+DIST cvs-fast-export-1.59.tar.gz 514934 BLAKE2B 2e9f42eb948c917785f80596bf176cde8265555c8808fa8c7a297217dba6eb36f8de6cebc192ebb0bd513e3c288beefad01d04cd59a72176377851b00a25419a SHA512 3fd4455c61b9065b784396683bea6ca6fcae8509fabd72531d1dba7d733e1fedeb9307b99d02f03eb3d19e9b024f2c53e2a15062b46d96fe58ab90651ff94bc5
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild
new file mode 100644
index 000000000000..abce092aa5b5
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.59.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}