summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-05-19 06:34:30 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-05-19 06:34:35 -0400
commit7bed6009ced41b08d98f16d85ffcbbb0d884a52c (patch)
tree0f8863cdf0dfd96896b790edddd7d59461dd0370 /dev-vcs/fossil/fossil-2.8.ebuild
parentnet-libs/libtorrent-rasterbar: Version bump (v1.2.1) (diff)
downloadgentoo-7bed6009ced41b08d98f16d85ffcbbb0d884a52c.tar.gz
gentoo-7bed6009ced41b08d98f16d85ffcbbb0d884a52c.tar.bz2
gentoo-7bed6009ced41b08d98f16d85ffcbbb0d884a52c.zip
dev-vcs/fossil: Bump to 2.8
Bug: https://bugs.gentoo.org/675778 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs/fossil/fossil-2.8.ebuild')
-rw-r--r--dev-vcs/fossil/fossil-2.8.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-vcs/fossil/fossil-2.8.ebuild b/dev-vcs/fossil/fossil-2.8.ebuild
new file mode 100644
index 000000000000..3f37e14e3a8b
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.27.1:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}