summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-01-13 18:25:31 +0100
committerSebastian Pipping <sping@gentoo.org>2021-01-13 18:32:47 +0100
commit23cd071cfb54f6616a8c7fdd46bbc3d2a1dd9cbe (patch)
tree7c68c4b58e07a2af9fa2aed07933d05563c2837c /dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
parentdev-vcs/repo: version bump to 2.11 (diff)
downloadgentoo-23cd071cfb54f6616a8c7fdd46bbc3d2a1dd9cbe.tar.gz
gentoo-23cd071cfb54f6616a8c7fdd46bbc3d2a1dd9cbe.tar.bz2
gentoo-23cd071cfb54f6616a8c7fdd46bbc3d2a1dd9cbe.zip
dev-vcs/git-big-picture: 1.0.0 (new package)
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to 'dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild')
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
new file mode 100644
index 000000000000..6672763d608f
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mv test.py test_some.py || die # help pytest with test discovery
+ default
+}