summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-03-31 21:00:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-10 10:40:28 +0300
commitbf2fb59fa3d3055d1395447c648a8108559fbe36 (patch)
tree4859866d0b5d560d04194c1fb07ebe91d3e3cf2b /dev-vcs/git-lfs
parentdev-vcs/git-lfs: Bump to 2.13.3 (diff)
downloadgentoo-bf2fb59fa3d3055d1395447c648a8108559fbe36.tar.gz
gentoo-bf2fb59fa3d3055d1395447c648a8108559fbe36.tar.bz2
gentoo-bf2fb59fa3d3055d1395447c648a8108559fbe36.zip
dev-vcs/git-lfs: Remove the old version
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/20211 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.13.1.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index bb66b3e4294e..97cc30d3e7fd 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,3 +1,2 @@
DIST git-lfs-2.11.0.tar.gz 2839623 BLAKE2B e9d0e8ea37f19617a4f727abdc93c3c937052ad98b6ac40de27ced6b250789701797d04f1bf795b259e83155e5d8a1ca122dbf8b40503c2c41d6d891a3ecf096 SHA512 2117b425864a36f773c14d34c78999636d836646184cf8d89045ef6de90cbded873d4de4613ecfafb0fa2ea8ae068e11f5ae22eed6af01715b5fac9be70f033b
-DIST git-lfs-2.13.1.tar.gz 2526962 BLAKE2B 3f3af1c0f976a17c108159fff15a065600f32af2a31d459fcd4b9e64d8e77aa8569aa81c932f38713ff6bafdb636aae464a2044f2664d124ca7de0a7157da969 SHA512 48397ed0ae976544c80df59df1991b0f35606d0a3ed9eb0aef66857e5bf2974e8ad5677be98b53433628d26f9e5135e9f28b15c8789cc6a4ed091946b79e6fce
DIST git-lfs-2.13.3.tar.gz 2901796 BLAKE2B 84bbce719e83229bbb7116f5c337e0748a2be223b260e03653dab23f6c8d20087a09695d6ef7abf45e128bfd79c5eb994cb14fb906330675174830603a2e3ba2 SHA512 2c9e10e4f2fdb5d6bae8994db5879f50596109f3057e7369a9edca3c13c3f4d77e268e3903a0abca60cf8e342ff54bc4920c01a530f8eb400e3a0cc11a171f74
diff --git a/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild b/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild
deleted file mode 100644
index 641f9c79a60b..000000000000
--- a/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-EGO_PN=github.com/git-lfs/git-lfs
-inherit go-module
-
-DESCRIPTION="Command line extension and specification for managing large files with git"
-HOMEPAGE="https://git-lfs.github.com/"
-
-if [[ "${PV}" = 9999* ]]; then
- EGIT_REPO_URI="https://${EGO_PN}"
- inherit git-r3
-else
- SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
-SLOT="0"
-IUSE="doc test"
-
-BDEPEND="doc? ( app-text/ronn )"
-RDEPEND="dev-vcs/git"
-
-RESTRICT+=" !test? ( test )"
-
-DOCS=(
- CHANGELOG.md
- CODE-OF-CONDUCT.md
- CONTRIBUTING.md
- README.md
- SECURITY.md
-)
-
-src_compile() {
- # Flags -w, -s: Omit debugging information to reduce binary size,
- # see https://golang.org/cmd/link/.
- local mygobuildargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
- -mod vendor -v -work -x
- )
- go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
-
- if use doc; then
- ronn docs/man/*.ronn || die "man building failed"
- fi
-}
-
-src_install() {
- dobin git-lfs
- einstalldocs
- use doc && doman docs/man/*.1
-}
-
-src_test() {
- local mygotestargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
- -mod vendor
- )
- go test "${mygotestargs[@]}" ./... || die
-}
-
-pkg_postinst () {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog ""
- elog "Run \'git lfs install\' once for each user account manually."
- elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
- fi
-}