summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-05 12:45:07 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-05 12:45:30 +0100
commitaad57d026506fbce86290e41d87d603b60c7f745 (patch)
tree3377f09b6fbc3c7a5003126d9857c866da2de17f /dev-vcs/git-num/git-num-2.0.1.ebuild
parentkde-apps/mplayerthumbs: amd64 stable wrt bug #569742 (diff)
downloadgentoo-aad57d026506fbce86290e41d87d603b60c7f745.tar.gz
gentoo-aad57d026506fbce86290e41d87d603b60c7f745.tar.bz2
gentoo-aad57d026506fbce86290e41d87d603b60c7f745.zip
dev-vcs/git-num: Initial version
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-vcs/git-num/git-num-2.0.1.ebuild')
-rw-r--r--dev-vcs/git-num/git-num-2.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/git-num/git-num-2.0.1.ebuild b/dev-vcs/git-num/git-num-2.0.1.ebuild
new file mode 100644
index 000000000000..bd4e97b74979
--- /dev/null
+++ b/dev-vcs/git-num/git-num-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Quickly reference files in Git using numbers"
+HOMEPAGE="https://github.com/schreifels/git-num"
+SRC_URI="https://github.com/schreifels/git-num/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ mkdir bin || die
+ mv git-num bin || die
+}