summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-03-20 22:25:27 +0800
committerYixun Lan <dlan@gentoo.org>2021-03-20 22:26:47 +0800
commit02bd8adbfa8d82598aed4ae71652dc84f35fe88a (patch)
tree644178fb5192c217feaeab935c5203534b471426 /dev-vcs/git-pw
parentsys-auth/libyubikey: Port to EAPI 7 (diff)
downloadgentoo-02bd8adbfa8d82598aed4ae71652dc84f35fe88a.tar.gz
gentoo-02bd8adbfa8d82598aed4ae71652dc84f35fe88a.tar.bz2
gentoo-02bd8adbfa8d82598aed4ae71652dc84f35fe88a.zip
dev-vcs/git-pw: fix missing version issue
thanks [Arfrever] for helping this Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/files/git-pw-2.0.0-version.patch11
-rw-r--r--dev-vcs/git-pw/git-pw-2.0.0.ebuild6
2 files changed, 4 insertions, 13 deletions
diff --git a/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch b/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
deleted file mode 100644
index 92706506c697..000000000000
--- a/dev-vcs/git-pw/files/git-pw-2.0.0-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/PKG-INFO b/PKG-INFO
-new file mode 100644
-index 0000000..9748ce5
---- /dev/null
-+++ b/PKG-INFO
-@@ -0,0 +1,5 @@
-+Metadata-Version: 2.1
-+Name: git-pw
-+Version: 2.0.0
-+Summary: A tool for integrating Git with Patchwork
-+Home-page: https://github.com/getpatchwork/git-pw
diff --git a/dev-vcs/git-pw/git-pw-2.0.0.ebuild b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
index 8efc99b1623b..a27a91f9a2c5 100644
--- a/dev-vcs/git-pw/git-pw-2.0.0.ebuild
+++ b/dev-vcs/git-pw/git-pw-2.0.0.ebuild
@@ -37,6 +37,8 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}/${P}-version.patch" )
-
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}
distutils_enable_tests pytest