summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2019-05-02 09:30:03 +0300
committerMichał Górny <mgorny@gentoo.org>2019-06-07 15:14:13 +0200
commite4babf672c04e54e8ad2fcf39ea2f298fa492650 (patch)
treeb065d3e63099459a2a9f4e3051da87b0c126caa0 /dev-vcs/git-remote-hg
parentdev-python/denonavr: remove old (diff)
downloadgentoo-e4babf672c04e54e8ad2fcf39ea2f298fa492650.tar.gz
gentoo-e4babf672c04e54e8ad2fcf39ea2f298fa492650.tar.bz2
gentoo-e4babf672c04e54e8ad2fcf39ea2f298fa492650.zip
dev-vcs/git-remote-hg: bump version to 1.0.1
setup.py was fixed upstream. Patch no longer needed. Closes: https://bugs.gentoo.org/684912 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Nikos Chantziaras <realnc@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs/git-remote-hg')
-rw-r--r--dev-vcs/git-remote-hg/Manifest1
-rw-r--r--dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-remote-hg/Manifest b/dev-vcs/git-remote-hg/Manifest
index 16b5236e9a50..ac7f4a97ddf8 100644
--- a/dev-vcs/git-remote-hg/Manifest
+++ b/dev-vcs/git-remote-hg/Manifest
@@ -1 +1,2 @@
DIST git-remote-hg-1.0.0.tar.gz 57611 BLAKE2B f46ca860bd7c46985ef53d5adfb949290208e351425a31fbfd33e6cf632c40b043397d398a5c378c653ab2b303d427c4b5bf29250fb51631f87cb2dbb0b541b5 SHA512 344349b8c64db5ad629176c664713773b4e8fe5ddf6bd13e7f3cac421f82eeb93fdd8aa59a2baab4b36b533cd6721adf8d31c69d4cc761e43c093c4d531c1a7d
+DIST git-remote-hg-1.0.1.tar.gz 57856 BLAKE2B 635073fbd0d9fe0ebbc2e9b5e49298bdb9f6b02f964219271a4bd930746e892e58fabde2afa94e998e4bd4aede91d9ac80291eef1bd3eb16cf82f6691514259b SHA512 b665cb6dc0564dc7f2cacade9000378f895b77a3186e091b841e58ddef37834e3cc87e81a76ab713997c6f837a768eff91d6b8a156c6277da0e34a2f156a5290
diff --git a/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild b/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild
new file mode 100644
index 000000000000..6351daeb396a
--- /dev/null
+++ b/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Semi-official Mercurial bridge from Git project"
+HOMEPAGE="https://github.com/mnauw/git-remote-hg"
+SRC_URI="https://github.com/mnauw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ app-text/asciidoc
+"
+RDEPEND="
+ dev-vcs/git
+ dev-vcs/mercurial
+"
+
+# Some tests fail.
+RESTRICT="test"
+
+src_compile() {
+ distutils-r1_src_compile
+ emake doc
+}
+
+src_install() {
+ distutils-r1_src_install
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-doc
+}
+
+src_test() {
+ default
+}