summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2016-12-12 16:36:07 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2016-12-20 10:41:03 -0700
commit4f878939d7495e9ab50e034ab262f6e25b7fe652 (patch)
treedcec051dc823f98a7c1375b2980db86d37a0a9f1 /dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
parentdev-python/whelk: New package (diff)
downloadgentoo-4f878939d7495e9ab50e034ab262f6e25b7fe652.tar.gz
gentoo-4f878939d7495e9ab50e034ab262f6e25b7fe652.tar.bz2
gentoo-4f878939d7495e9ab50e034ab262f6e25b7fe652.zip
dev-vcs/git-spindle: Updated dependencies
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild')
-rw-r--r--dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
new file mode 100644
index 000000000000..82277c2be56f
--- /dev/null
+++ b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Git subcommands for interacting with central services"
+HOMEPAGE="http://seveas.github.io/git-spindle/"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ dev-python/github3[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/whelk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"