summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-05-07 21:36:02 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-05-07 21:36:12 -0700
commita6536e1226c20495cd281fd3b08d4c396c3bd822 (patch)
treefb40c98dd1846adb0eefd0d6c58a0e241edef552 /dev-vcs/git-tools
parentnet-libs/socket_wrapper: enable unit tests (diff)
downloadgentoo-a6536e1226c20495cd281fd3b08d4c396c3bd822.tar.gz
gentoo-a6536e1226c20495cd281fd3b08d4c396c3bd822.tar.bz2
gentoo-a6536e1226c20495cd281fd3b08d4c396c3bd822.zip
dev-vcs/git-tools: bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-vcs/git-tools')
-rw-r--r--dev-vcs/git-tools/Manifest1
-rw-r--r--dev-vcs/git-tools/git-tools-2019.11.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-vcs/git-tools/Manifest b/dev-vcs/git-tools/Manifest
index 38d383b8c74d..270fa4cf04ac 100644
--- a/dev-vcs/git-tools/Manifest
+++ b/dev-vcs/git-tools/Manifest
@@ -1 +1,2 @@
DIST git-tools-2017.10.tar.gz 28049 BLAKE2B 64b5f90468226dbeb4222f0f7be77846deffa836d6743e970c9bffced699c563712c24851e112a922faf3ae4b56ecc8daf0f5f772936c43a95c3907a244a6efa SHA512 60b3006de64a4c26f00241b60d45ef8258999dabfc0a8ad1c7d6d6b386dc56caf8c3b6cd0edbce5e27277c8f900b736fe1e26c6a68ee2179f563d00d65fd7cfe
+DIST git-tools-2019.11.tar.gz 28769 BLAKE2B 97dc7dd238b921075cd82cce9a0368309c9cbfd946715063cc05d0638987c81ae81dda10a6a24f8753a6e84bd558c86efea0bbc743d0a63265187924b66536d7 SHA512 091186d78f69bbc5c7b4673d1a3018d642aaf1b6820d7d995712bb41e9da861576f1ad780c5d2380ba75f80843e7cf101bc9e2409bd36f7dcbdb78fe923a8736
diff --git a/dev-vcs/git-tools/git-tools-2019.11.ebuild b/dev-vcs/git-tools/git-tools-2019.11.ebuild
new file mode 100644
index 000000000000..37ed8e1ea2d2
--- /dev/null
+++ b/dev-vcs/git-tools/git-tools-2019.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-r1
+
+DESCRIPTION="Assorted git-related scripts"
+HOMEPAGE="https://github.com/MestreLion/git-tools"
+SRC_URI="https://github.com/MestreLion/git-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-2.5
+ >=app-shells/bash-4.0"
+
+src_install() {
+ dobin git-branches-rename git-clone-subset git-find-uncommitted-repos
+ dobin git-rebase-theirs git-strip-merge
+ python_foreach_impl python_doscript git-restore-mtime
+ doman man1/*.1
+ einstalldocs
+}