summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-06 16:12:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-06 16:34:10 +0200
commitf99a9cecf5aa761f52834a95f64483ecab94376a (patch)
treeb08e5b7f50d63dff1649eca4b6a3b37a051b7f79 /dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch
parentdev-libs/re2: bump to 2018-04-01 (diff)
downloadgentoo-f99a9cecf5aa761f52834a95f64483ecab94376a.tar.gz
gentoo-f99a9cecf5aa761f52834a95f64483ecab94376a.tar.bz2
gentoo-f99a9cecf5aa761f52834a95f64483ecab94376a.zip
dev-vcs/git: Revbump to fix installation of MediaWiki perl module
Removed old. Closes: https://bugs.gentoo.org/655960 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch')
-rw-r--r--dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch b/dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch
new file mode 100644
index 000000000000..5a66a4c89be0
--- /dev/null
+++ b/dev-vcs/git/files/git-2.17.0-mw_install_path_fix.patch
@@ -0,0 +1,48 @@
+From cfb3a47cada99d1bdccd08426f122ded2a63834e Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Tue, 10 Apr 2018 15:36:41 +0200
+Subject: [PATCH] perl: fix installing modules from contrib
+
+Commit 20d2a30f (Makefile: replace perl/Makefile.PL with simple make rules)
+removed a target that allowed Makefiles from contrib/ to get the correct
+install path. This introduces a new target for main Makefile and fixes
+installation for Mediawiki module.
+
+v2: Pass prefix as that can have influence as well, add single quotes
+ for _SQ variant.
+
+Signed-off-by: Christian Hesse <mail@eworm.de>
+---
+ Makefile | 2 ++
+ contrib/mw-to-git/Makefile | 5 +++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2091f5f892cc8..75b9ad3b480cb 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1973,6 +1973,8 @@ GIT-PERL-DEFINES: FORCE
+ echo "$$FLAGS" >$@; \
+ fi
+
++perllibdir:
++ @echo '$(perllibdir_SQ)'
+
+ .PHONY: gitweb
+ gitweb:
+diff --git a/contrib/mw-to-git/Makefile b/contrib/mw-to-git/Makefile
+index a4b6f7a2cd412..4e603512a39fe 100644
+--- a/contrib/mw-to-git/Makefile
++++ b/contrib/mw-to-git/Makefile
+@@ -21,8 +21,9 @@ HERE=contrib/mw-to-git/
+ INSTALL = install
+
+ SCRIPT_PERL_FULL=$(patsubst %,$(HERE)/%,$(SCRIPT_PERL))
+-INSTLIBDIR=$(shell $(MAKE) -C $(GIT_ROOT_DIR)/perl \
+- -s --no-print-directory instlibdir)
++INSTLIBDIR=$(shell $(MAKE) -C $(GIT_ROOT_DIR)/ \
++ -s --no-print-directory prefix=$(prefix) \
++ perllibdir=$(perllibdir) perllibdir)
+ DESTDIR_SQ = $(subst ','\'',$(DESTDIR))
+ INSTLIBDIR_SQ = $(subst ','\'',$(INSTLIBDIR))
+